Help with Intel compilation

Barry Moore moor... at
Fri Feb 2 21:48:50 UTC 2018


I will try that. I also would like to see if I can build a working cp2k 5.1 
install with Intel compilers, as well as the toolchain style builds w/ 4.1 
and 5.1.

By the way, the trick to getting this to run fast was removing libint. A 
lot of other QM packages are using that code with good speedups, but the 
recommendations/defaults in CP2K don't seem to yield good performance at 
our center.

- Barry

On Friday, February 2, 2018 at 3:55:43 AM UTC-5, Alfio Lazzaro wrote:
> Oh yes, the situation is definitely better... 
> Concerning the wrong results, I noticed that you are using 12 ranks in 
> your regtest (is this correct?). Some of the tests have references that 
> depend on the number of ranks (usually we set it to 2 or 4 ranks), 
> therefore I assume that if your run with 2 ranks the problem will go away. 
> Could you test it? Then, there are only *primary* 4 tests that are failing. 
> At this point, I don't know where the problem is, but likely it is an 
> effect of the 12 ranks...
> Alfio
> Il giorno venerdì 2 febbraio 2018 01:39:13 UTC+1, Barry Moore ha scritto:
>> Alfio,
>> I borrowed a Linux-x86-64-intel-mic.psmp which I know to be working 
>> somewhere else (we are regtesting that version now) for cp2k 4.1. It is 
>> definitely a lot better than before, but I still get some failures. I 
>> attach the arch file and error_summary. Any comments?
>> - Barry
>> On Thursday, February 1, 2018 at 4:21:18 PM UTC-5, Barry Moore wrote:
>>> For reference, this didn't work. Same failures.
>>> On Tuesday, January 30, 2018 at 12:54:29 PM UTC-5, Barry Moore wrote:
>>>> Alfio,
>>>> Thanks a lot for that tip, I am working on compiling/regtesting now. 
>>>> Fingers crossed.
>>>> I do think cleaning up the arch directory would be really helpful for 
>>>> administrators. 
>>>> Best,
>>>> Barry
>>>> On Tuesday, January 30, 2018 at 4:23:34 AM UTC-5, Alfio Lazzaro wrote:
>>>>> Hello Barry,
>>>>> The arch you are using (Linux-x86-64-intel-mic.psmp) is pretty old and 
>>>>> messy (it refers to Intel KNC with offload mode). Sorry about that, I will 
>>>>> update it for the next release.
>>>>> Now, we do test CP2K with Intel compiler in our dashboard: 
>>>>> For instance, this test
>>>>> has an arch file (see on top of the log). We test ICC version 17.0.4, 
>>>>> which is pretty outdated now. 
>>>>> It can be that there are some bugs in the newer ICC version (we have 
>>>>> seen this in the past). I would suggest you use the arch file from the 
>>>>> dashboard, set -O0 mode, and try to run the regtests. Intel people told us 
>>>>> to use "-fp-model precise" can be useful as well... 
>>>>> Alfio
>>>>> Il giorno lunedì 29 gennaio 2018 16:15:24 UTC+1, Barry Moore ha 
>>>>> scritto:
>>>>>> Hello All,
>>>>>> I will preface this by stating I am not a CP2K user. I support CP2K 
>>>>>> users.
>>>>>> I have compiled CP2K a few times using the toolchain style with all 
>>>>>> of the
>>>>>> plugins (4.1, 5.1 w/ Intel MKL 2017.1.132). I have found that if I 
>>>>>> use Intel
>>>>>> MKL 2017.3.196 neither version 4.1 nor 5.1 passes regression tests. 
>>>>>> Anyway, recently a
>>>>>> student showed me some scaling plots and they are atrocious. I need to
>>>>>> reconcile this because the major users at our center are all using 
>>>>>> CP2K and I
>>>>>> am basically throwing away computer time on one of our busiest 
>>>>>> resources.
>>>>>> So, I built an arch file starting from Linux-x86-64-intel-mic.psmp 
>>>>>> (`h2p.psmp`
>>>>>> attached). I ignored ACC & MIC stuff and tried to simplify the MKL 
>>>>>> section.
>>>>>>  I installed libxc and libint by modifying the toolchain scripts
>>>>>> (scripts attached). Finally, I attach the regression log
>>>>>> (`cp2k-regtest-5.1.log`). Any help is appreciated.
>>>>>> Thanks,
>>>>>> Barry
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the CP2K-user mailing list