[CP2K:8563] error in qs_ks_methods.F depending on number of cores (intel compiler)

Iain Bethune i.be... at epcc.ed.ac.uk
Thu Jan 19 15:57:37 CET 2017


Hi Laurent,

We don’t have experience yet with exactly that version (ifort 17.0.1), but with the 17.0.0 compiler we find that a couple of files need to be built at reduced optimisation level - see https://dashboard.cp2k.org/archive/epcc-phi-psmp/rev_17693.txt for an example arch file which is working.

Were you able to run the CP2K regression tests with success?

Cheers

- Iain

--

Iain Bethune
Project Manager, EPCC

Email: i.be... at epcc.ed.ac.uk
Twitter: @IainBethune @PrimeGrid @CP2Kproject
Web: http://www2.epcc.ed.ac.uk/~ibethune
Tel/Fax: +44 (0)131 651 7183/6555
Mob: +44 (0)7598317015
Addr: 2404 JCMB, The King's Buildings, Peter Guthrie Tait Road, Edinburgh, EH9 3FD

> On 19 Jan 2017, at 14:51, Laurent Joly <ljoly... at gmail.com> wrote:
> 
> Dear all, 
> 
> I've been trying to compile CP2K 4.1 (I also tried with the 3.0 version) using the intel compiler version 2017.1.132. 
> 
> I used the Linux-x86-64-intel-host.popt and Linux-x86-64-intel-host.psmp arch files, and I had to modify the Linux-x86-64-intel-mic.psmp file following the instructions of the intel mkl link line advisor:  https://software.intel.com/en-us/articles/intel-mkl-link-line-advisor to make it work: 
> 
> $ diff Linux-x86-64-intel-mic.psmp.backup Linux-x86-64-intel-mic.psmp
> 231d230
> <             $(MKLROOT)/lib/intel64/libmkl_core.a \
> 233,234c232,234
> <           -Wl,--end-group \
> <           $(MKLROOT)/lib/intel64/libmkl_blacs_intelmpi_lp64.a
> ---
> >             $(MKLROOT)/lib/intel64/libmkl_core.a \
> >             $(MKLROOT)/lib/intel64/libmkl_blacs_intelmpi_lp64.a \
> >           -Wl,--end-group
> 
> Then I had to run: ulimit -s unlimited in order to get rid of segmentation faults, and finally it worked... on 16 cores, but as soon as I tried to increase the number of cores I got this error message: 
> 
> KS energy is an abnormal value (NaN/Inf).
> qs_ks_methods.F:785
> 
> I enclose the complete output. Do you have some ideas on what could be the problem?
> 
> Best regards, 
> Laurent
> 
> 
> -- 
> You received this message because you are subscribed to the Google Groups "cp2k" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to cp2k+uns... at googlegroups.com.
> To post to this group, send email to cp... at googlegroups.com.
> Visit this group at https://groups.google.com/group/cp2k.
> For more options, visit https://groups.google.com/d/optout.
> <out>


-- 
The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.




More information about the CP2K-user mailing list