error in qs_ks_methods.F depending on number of cores (intel compiler)

Laurent Joly ljoly... at gmail.com
Thu Jan 19 15:51:03 CET 2017


Dear all, 

I've been trying to compile CP2K 4.1 (I also tried with the 3.0 version) 
using the intel compiler version 2017.1.132. 

I used the Linux-x86-64-intel-host.popt and Linux-x86-64-intel-host.psmp 
arch files, and I had to modify the Linux-x86-64-intel-mic.psmp file 
following the instructions of the intel mkl link line advisor:  
https://software.intel.com/en-us/articles/intel-mkl-link-line-advisor to 
make it work: 

$ diff Linux-x86-64-intel-mic.psmp.backup Linux-x86-64-intel-mic.psmp
231d230
<             $(MKLROOT)/lib/intel64/libmkl_core.a \
233,234c232,234
<           -Wl,--end-group \
<           $(MKLROOT)/lib/intel64/libmkl_blacs_intelmpi_lp64.a
---
>             $(MKLROOT)/lib/intel64/libmkl_core.a \
>             $(MKLROOT)/lib/intel64/libmkl_blacs_intelmpi_lp64.a \
>           -Wl,--end-group

Then I had to run: ulimit -s unlimited in order to get rid of segmentation 
faults, and finally it worked... on 16 cores, but as soon as I tried to 
increase the number of cores I got this error message: 

KS energy is an abnormal value (NaN/Inf).
qs_ks_methods.F:785

I enclose the complete output. Do you have some ideas on what could be the 
problem?

Best regards, 
Laurent

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20170119/1d0598f5/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: out
Type: application/octet-stream
Size: 9879 bytes
Desc: not available
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20170119/1d0598f5/attachment.obj>


More information about the CP2K-user mailing list