neither PGI nor Intel compiler working?

NUCP2K chenh... at gmail.com
Tue Oct 27 07:33:55 CET 2009


Hi guys,

  With your generous helps, I just got the latest CVS snapshot on
running on Macintosh OSX using gfortran compiler. I am hoping the code
work for Intel or PGI compilers soon.....

  Thanks.

Hanning

ARCH file for my Intel Mac:

CC       = cc
CPP      =
FC       = gfortran
LD       = gfortran
AR       = ar -r
CPPFLAGS = -D__GFORTRAN -D__FFTSG
FCFLAGS  = -cpp -O3  -fopenmp -ffree-form $(CPPFLAGS)
FCFLAGS2 = -cpp -O3  -fopenmp -ffree-form $(CPPFLAGS)
LDFLAGS  = $(FCFLAGS)
LIBS     = -llapack -lblas

OBJECTS_ARCHITECTURE = machine_gfortran.o




On Oct 26, 11:36 am, Ondrej Marsalek <ondrej.... at gmail.com>
wrote:
> Teo,
>
> I thought I did use the wrapper, but perhaps there was a mistake in my
> setup. I will recheck and retry.
>
> Thanks,
> Ondrej
>
>
>
> On Mon, Oct 26, 2009 at 17:33, Teodoro Laino <teodor... at gmail.com> wrote:
>
> > that's because you tried the ISO_C_BINDING with gfortran (which was
> > probably broken or not fully working with that version). Nonetheless, if
> > the rest of cp2k was properly compiled, there is no reason why with
> > gfortran you had to be stuck with ISO_C_BINDING. You may have as well
> > tried the additional cpp wrapper, which does not need any ISO_C_BINDING
> > capability of the fortran compiler. See:
>
> > cp2k/tools/hfx_tools/libint_tools/README_LIBINT
>
> > so quite probably you may have been able as well to compile cp2k with
> > 4.3.2, even with libint (of course relying on the absence of  other
> > compiler bugs, which may have potentially misinterpreted other parts of
> > cp2k: the  function pointer is only required in the ISO_C_BINDING
> > instructions)
>
> > Teo


More information about the CP2K-user mailing list