[CP2K:2362] Re: neither PGI nor Intel compiler working?

Ondrej Marsalek ondrej.... at gmail.com
Mon Oct 26 17:36:57 CET 2009


Teo,

I thought I did use the wrapper, but perhaps there was a mistake in my
setup. I will recheck and retry.

Thanks,
Ondrej


On Mon, Oct 26, 2009 at 17:33, Teodoro Laino <teodor... at gmail.com> wrote:
>
> that's because you tried the ISO_C_BINDING with gfortran (which was
> probably broken or not fully working with that version). Nonetheless, if
> the rest of cp2k was properly compiled, there is no reason why with
> gfortran you had to be stuck with ISO_C_BINDING. You may have as well
> tried the additional cpp wrapper, which does not need any ISO_C_BINDING
> capability of the fortran compiler. See:
>
> cp2k/tools/hfx_tools/libint_tools/README_LIBINT
>
>
> so quite probably you may have been able as well to compile cp2k with
> 4.3.2, even with libint (of course relying on the absence of  other
> compiler bugs, which may have potentially misinterpreted other parts of
> cp2k: the  function pointer is only required in the ISO_C_BINDING
> instructions)
>
> Teo
>
> >
>



More information about the CP2K-user mailing list