[CP2K:2361] Re: neither PGI nor Intel compiler working?

Jörg Saßmannshausen jorg.sassm... at strath.ac.uk
Tue Oct 27 18:50:41 CET 2009


Hi Ondrej,

yes, that cp2k code I compiled with the mentioned gfortran compiler was with 
libint (version libint-1.1.4).
I know you need the wrappter for some compilers, but I took that as granted.

All the best

Jörg

On Montag 26 Oktober 2009 Ondrej Marsalek wrote:
> Hi,
>
> On Mon, Oct 26, 2009 at 17:13, Jörg Saßmannshausen
>
> <jorg.sassm... at strath.ac.uk> wrote:
> > Hi all,
> >
> > unless I am mistaken, libint is c++ code, so the fortran compiler does
> > not matter.
>
> It is true that it does not matter for the compilation of libint itself.
> However, you need to link this code to Fortran code and then the Fortran
> compiler does matter. You either need full ISO_C_BINDING support, or an
> additional wrapper. For details see the file
>
> cp2k/tools/hfx_tools/libint_tools/README_LIBINT
>
> > Besides, I have build (albeit an older version) of cp2k with gfortran
> > 4.3.2.
>
> Was that with libint? I certainly got complaints about support for
> function pointers with gfortran 4.3.2.
>
> Best,
> Ondrej
>
> 


-- 
*************************************************************
Jörg Saßmannshausen
Research Fellow
University of Strathclyde
Department of Pure and Applied Chemistry
295 Cathedral St.
Glasgow
G1 1XL

email: jorg.sassm... at strath.ac.uk
web: http://sassy.formativ.net

Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html



More information about the CP2K-user mailing list