Segmentation fault (x86-64)

Toon Toon.Ver... at
Mon Apr 30 14:38:17 UTC 2007


We are compiling cp2k on a an x86-64 machine. Both the serial and the
parallel version have the same problem that cp2k segfaults when it
starts an scf cycle. We have tried three fft implementation (fftsg,
fftw3 and fftmkl). The error on the console looks like this:

rank 0 in job 1 moldyn48_36535 caused collective abort of all ranks
exit status of rank 0: killed by signal 11

Only when we specify a large number of parallel processes (-np 16),
the problem disappears. When we do the same test with H2O-32.inp from
the tests directory, 2 processes are sufficient, but one is not. This
is probably a memory related problem because the memory requirements
per process decrease when we use a higher number of processes. In
principle this should not happen since we are working on 64bit
machines. Have other people experienced the same problem? Maybe our
arch files are not perfect? Our arch files and an example output file
can be found at:

P.S. We have tried the -i8 option for the intel compiler but this had
no effect on the serial version and it broke the parallel version.

More information about the CP2K-user mailing list