[CP2K-user] [CP2K:17334] Re: Operating system error: Cannot allocate memory Allocation would exceed memory limit

Jessie wang wangchuyan123 at gmail.com
Wed Jul 20 09:34:22 UTC 2022

Dear Mat,

Thank you so much for the reply. 

I tried a lot but none of them works. So I re-compiled cp2k and now it 
looks fine ~

Restart and recompile are the most useful strategies, lol ~


On Tuesday, July 19, 2022 at 7:20:38 PM UTC+8 mattwa... at gmail.com wrote:

> Hello,
> without full setup we can't completely reproduce your problem.
> The slowdown sounds like a memory leak - this is unlikely to come from 
> CP2K itself as it is pretty well tested for such calculations. 
> The later message suggests that your MPI setup might be causing the 
> problem. Do you have different MPI environments on your cluster you could 
> try or are there FAQs with common problems that might suggest a solution?
> You could try just running without MPI using a cp2k.ssmp executable and 
> see if the memory problem went away.
> Without full details probably can't say anything else. I'd suggest talking 
> to your cluster support and see if they can suggest something.
> Matt
> On Tuesday, 19 July 2022 at 12:02:08 UTC+1 wangch... at gmail.com wrote:
>> Another failed apears~
>> [image: QQ20220719-190139 at 2x.png]
>> On Tuesday, July 19, 2022 at 6:24:21 PM UTC+8 Jessie wang wrote:
>>> Dear All,
>>> I am performing a geometry optimization of a Au cluster by 1 node, 96 
>>> core,  using PBE and DZVP-MOLOPT-SR-GTH. I think this should be a simple 
>>> process, but it went wrong. 
>>> At the beginning it went well and each SCF step took 7~8s and SCF 
>>> converged very fast. But after 1-2 hours it became very slow, each SCF step 
>>> took several hundred seconds and the 3000s. And finally it went down. I 
>>> tried it several times until I noticed that the memory occupied by cp2k was 
>>> increasing linearly, i.e. it never released the memory. 
>>> I tried cp2k9.1 and cp2k8.3, all went wrong.I’m really confused and 
>>> don’t know what to do.
>>> I am really appreaciate it if you can help me with this problem.
>>> Best,
>>> Jessie

You received this message because you are subscribed to the Google Groups "cp2k" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cp2k+unsubscribe at googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cp2k/d6598a05-91a0-4a2c-8104-8507a9624071n%40googlegroups.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20220720/4d532bd4/attachment-0001.htm>

More information about the CP2K-user mailing list