[CP2K-user] "Non-zero exit code detected." when compile cp2k 7.1

Jiayu Sun SLE sunjia... at gmail.com
Fri Jun 12 18:44:15 UTC 2020


Hi Anton
Thank you for your kindly help and patience.

Now, I installed some packages and rerun the sh script and almost all the 
packages are installed, then the code skips, but only two packages shows 
error message, I print here:

==================== Installing ScaLAPACK ====================
scalapack-2.0.2.tgz is found
Installing from scratch into 
/home/jiayusun/Downloads/cp2k-7.1/tools/toolchain/install/scalapack-2.0.2
ERROR: (./scripts/install_scalapack.sh, line 47) Non-zero exit code 
detected.
==================== Installing ELPA ====================
elpa-2019.05.001.tar.gz is found
Installing from scratch into 
/home/jiayusun/Downloads/cp2k-7.1/tools/toolchain/install/elpa-2019.05.001
ERROR: (./scripts/install_elpa.sh, line 84) Non-zero exit code detected.
Step ptscotch took 0.00 seconds.
Step parmetis took 0.00 seconds.
Step metis took 0.00 seconds.
Step superlu took 0.00 seconds.
Step pexsi took 0.00 seconds.
Step quip took 0.00 seconds.
Step plumed took 0.00 seconds

I tried to install Scalapack by myself, before that, the packages of blas,  
lapcak, cblas are all installed successfully, but the installation of 
Scalapack failed eventually.
It's a tough way, now only two packages left, can you give me some advice?

Thank you so much!!


在 2020年6月11日星期四 UTC+9下午12:08:21,Jiayu Sun SLE写道:
>
> Hi, everyone,
> I have tried compiled the cp2k 7.1 version from toolchain script, the *sh 
> file, and using the OpenBLAS 0.3.6, the error message are listed below:
>
> ==================== Installing OpenBLAS ====================
> OpenBLAS-0.3.6.tar.gz is found
> Installing from scratch into 
> /home/jiayusun/Downloads/cp2k-7.1/tools/toolchain/install/openblas-0.3.6
> patching file kernel/x86_64/KERNEL.SKYLAKEX
> ERROR: 
> (/home/jiayusun/Downloads/cp2k-7.1/tools/toolchain/scripts/install_openblas.sh, 
> line 72) Non-zero exit code detected.
> ERROR: (./scripts/install_mathlibs.sh, line 34) Non-zero exit code 
> detected.
>
>
> How can I do this in this case?
> What the meaning of this sentence: "Non-zero exit code detected." When I 
> compile other packages, this error occurs again, almost all the packages 
> are facing the same problem.
>
> Thank you for your help or advice.
>
> Sincerely
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20200612/e77091f3/attachment.html>


More information about the CP2K-user mailing list