[CP2K-user] CP2K 7.1 memory leak

Paul Schwarz paul.... at freudenberg.com
Tue Aug 11 11:54:19 UTC 2020

Dear CP2K developers,


I downloaded the latest 7.1 version and used toolchain to install the 
libraries libint, libxc, and libxsmm with the following command:


$ ./install_cp2k_toolchain.sh --enable-omp --with-libxc=install 
--with-libint=install --with-fftw=system --with-libxsmm=install 
--with-mkl=system  --with-elpa=no --with-cmake=system --with-openblas=no 


After the successfull installations, I used the resulting local.popt to 
make an executable (without any further modifications).

The used compilers were gcc, g++, and mpif90, which in my case is Intel 
version 2019.5.281, and not OpenMPI.


Running relaxation simulations of molecules on slab surfaces, I experience 
an increasing memory usage.

Sometimes the simulation relaxes fast enough, so that I don’t run out of 

Sometimes I run out of memory before the relaxation finishes.

I call cp2k_shell.popt, since I run my relaxations via an ase interface 
(but I guess it doesn’t matter, since there is no shell binary, but just a 
link of the shell to cp2k.popt).


Does anyone else experience memory issues? I have the same issue on a HPC 
center, where a system admin installed the 7.1 version for me, and here my 
jobs also crash due to running out of memory. 

Does someone have a suggestion as to what the problem is or how to avoid it?

Is there maybe a compiler flag/option I should avoid or put in?



Best regards,

Paul Schwarz
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20200811/6ad006ba/attachment.htm>

More information about the CP2K-user mailing list