Compiling CP2K 4.1 with CUDA 8 (or The Long and Winding Road)

Alfio Lazzaro alfio.... at
Fri Sep 29 08:27:36 UTC 2017

Hello Henrique,
I see that you are using CP2K 4.1, which is based on SVN revision r17462. 
Now, your problem appears to be fixed with revision r17471 (5 days after 
the release):

Therefore I would suggest you move to the CP2K SVN trunk version to get the 
last fixes (there are other CUDA 8 related commits). BTW, as rule of thumb, 
I would always suggest trying the trunk version to see if bugs are fixed 
there (it can save you a lot of time). Also, note that OpenCL version is 
not supported anymore.
Please, note that a new official CP2K release will come in October, so you 
can think to upgrade to it.

I hope this helps!

Best regards,


Il giorno giovedì 28 settembre 2017 20:23:29 UTC+2, Henrique Junior ha 
> Dear colleagues, I’m part of Professor Graucio Braga’s Team at UFF in 
> Brazil and we’re trying to build CP2K to work with our Nvidia GPUs. After 
> several hours and many (many, many many) attempts our compilation aways 
> fail complaining about something libcusmm related (please, see the logs 
> attached). We have tried several hints posted on this forum and a lot of 
> Google searches. We are running a Fedora 26 box but we also tried Ubuntu 
> 16.04 and 17.04 with no luck so far (even with OpenCL that fails at the 
> same point).
> Any help with this matter is much appreciated
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the CP2K-user mailing list