Intel compiler 2017+openmpi2.1.1

Luca lcb... at
Fri Jun 30 13:32:26 UTC 2017

Dear all, 
i tried to compile several times  cp2k with new version of 
 ifort-2017update4 without success.
Here I tried to compile the serial version
with the following arch-file: 
CC       = cc
CPP      = 
FC       = ifort 
LD       = ifort 
AR       = ar -r

FCFLAGS   = $(DFLAGS) -O0 -g -traceback -fpp -free -I$(MKLROOT)/include 
LDFLAGS   = $(FCFLAGS) -static-intel 
LDFLAGS_C = $(FCFLAGS) -static-intel -nofor_main
LIBS      = -Wl,--start-group \
   $(MKLROOT)/lib/intel64/libmkl_intel_lp64.a \
   $(MKLROOT)/lib/intel64/libmkl_sequential.a \
   $(MKLROOT)/lib/intel64/libmkl_core.a \
   -Wl,--end-group \
   -lpthread -lm -lstdc++

I compiled the program, but I noticed that there 
are some errors the regtest (output is in the attache file). 

Any suggestion?

cp2k4.1 REVISION="\"svn:17462\
Intel(R) Fortran Intel(R) 64 Compiler for applications running on Intel(R) 
64, Version Build 20170411


On Thursday, June 29, 2017 at 10:45:05 PM UTC+2, Luca wrote:
> Dear all,
> someone have tried to compile cp2k 4.1 or current trunk, with  intel 
> parallel_studio_xe_2017_update4 and openmpi2.1.1 and,
> eventually, could share the arch file and/or  its experience.
> Thanks in advance.
> Cheers, 
> Luca
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: regtest_out
Type: application/octet-stream
Size: 795535 bytes
Desc: not available
URL: <>

More information about the CP2K-user mailing list