Compilling problems

rdela... at rdela... at
Tue Feb 14 12:40:09 UTC 2017

Hello and thank you Jörg

I compile the next arch file:

CC         = gcc
CPP        =
FC         = gfortran
LD         = gfortran
AR         = ar -r
ACML_INC   = /home/ralf/ACML/gfortran64_mp/include
ACML_LIB   = /home/ralf/ACML/gfortran64_mp/lib
FFTW_INC   = /usr/local/include/
FFTW_LIB   = /usr/local/lib/
LIBINT_INC = /usr/local/libint/1.1.4-stable/include
LIBINT_LIB = /usr/local/libint/1.1.4-stable/lib
LIBXC_INC  = /opt/etsf/include
LIBXC_LIB  = /opt/etsf/lib
             -D__LIBINT_MAX_AM=7 -D__LIBDERIV_MAX_AM1=6 -D__MAX_CONTR=4
FCFLAGS    = $(DFLAGS) -O2 -ffast-math -ffree-form -ffree-line-length-none\
             -fopenmp -ftree-vectorize -funroll-loops\
             -I$(ACML_INC) -I$(FFTW_INC) -I$(LIBINT_INC) -I$(LIBXC_INC)
LDFLAGS    = $(FCFLAGS) -static-libgfortran
LIBS       = $(ACML_LIB)/\

And when I run the tests I obtain in all 2500 cases this kind of error

error while loading shared libraries: cannot open shared 
object file: No such file or directory

I should use libacml_mp.a for the compilling but in my installation this 
file doesn appear


El martes, 14 de febrero de 2017, 13:11:16 (UTC+1), rdel... at 
> Hello all.
> I have been trying to compile and execute cp2k in my computer but i'm 
> having problems.
> I use a modified arch file including my routes to files and libreries. 
> When I compile it works but wher runing the tests it fails in all the cases.
> Could anyone help me with this? My computer is an intel i7-920 with 4 
> cores and 8 threadings. I have a CUDA capable graphic card so i like to 
> enable it (I have installed the last version of the nvidia CUDA kit)
> About the software i run ubuntu 16.04.4 with gfortran and gcc, both 
> versions 5.4.0. Also I have installed the last version of the intel MKL 
> library (aditionally i also have ACML). Finally I'd like to compile cp2k 
> with libint, libxc and fftw. All three are compiled and installed in my 
> computer
> Any help for the creation of the appropiate arch file in wellcome.
> That you all in advance.
> Rafa
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the CP2K-user mailing list