Runtime issue: CP2K not writing anything to the output after some time

elbu... at gmail.com elbu... at gmail.com
Fri Nov 4 14:45:29 CET 2016


Dear all, 
 
My name is Fabio and I am having problems installing CP2K on the new Santos 
Dumont Brazilian cluster, that has Intel Xeon E5-2695v2 processors  
(http://sdumont.lncc.br/machine.php?pg=machine#). I am not an expert in 
this topic but I have successfully installed CP2K in several different 
architectures, with both gfortran and intel compilers. Since I am not a 
superuser in this cluster I don't have access to the nodes, I can't "ssh" 
them, so I am not sure what is going on and maybe somebody here can help 
me. 
 
Below you can find the last makefile I tried (I have several). It is the 
simplest one I could make. The installation always goes smooth, without any 
errors. But during runtime the code stops writing anything in the output 
after 1-2hours, not even error messages. The input used is attached to this 
e-mail, but all inputs I've tried so far have failed, and they have all 
been successfully run in other clusters/machines. Wave functions are not 
updated, but the code keeps running and the job is not killed.  
 
The administrators from the cluster told me that the nodes still have 
"Nproc" cp2k processes running during the whole time the job lives, even 
after it stops updating the outputs. I have searched for similar issues in 
the forum and they gave me the idea of reducing the number of processors 
or/and reducing the optimization level, using -O1/O0 flags. But even after 
trying this the problem still happens, not after 1-2hours but after, say, 8 
hours. It depends a lot on the system/makefile used. 
 
Does someone have any tips on what is going on, what could be tried, or 
what flag to use so I can collect more information during runtime that 
might help elucidating the problem!?

Thanks very much for your time and all the best!

Fabio Negreiros Ribeiro
Post-Doc, Federal University of ABC, Santo André, Brazil

*** Makefile ***
CC       = cc
CPP      =
FC       = mpiifort
LD       = mpiifort
AR       = ar -r

CPPFLAGS =
DFLAGS   = -D__MKL -D__FFTW3 -D__parallel -D__SCALAPACK
CFLAGS   = $(DFLAGS)
MKLROOT = 
/opt/intel/parallel_studio_xe_2016_update2/compilers_and_libraries_2016.2.181/linux/mkl
FCFLAGS  = $(DFLAGS) -O2 -g -traceback -fpp -free \
           -I$(MKLROOT)/include -I$(MKLROOT)/include/fftw
LDFLAGS  = $(FCFLAGS) -static-intel
LDFLAGS_C = $(FCFLAGS) -static-intel -nofor_main
LIBS     = $(MKLROOT)/lib/intel64/libmkl_scalapack_lp64.a \
         -Wl,--start-group  $(MKLROOT)/lib/intel64/libmkl_intel_lp64.a \
         $(MKLROOT)/lib/intel64/libmkl_sequential.a \
         $(MKLROOT)/lib/intel64/libmkl_core.a \
         $(MKLROOT)/lib/intel64/libmkl_blacs_intelmpi_lp64.a 
-Wl,--end-group \
         -lpthread -lm \
*** End ***
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20161104/a1abcd9f/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 1H2O_O-Term_2x2.relax.inp
Type: chemical/x-gamess-input
Size: 11227 bytes
Desc: not available
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20161104/a1abcd9f/attachment.inp>


More information about the CP2K-user mailing list