problems with compilation of QUIP

Jörg Saßmannshausen j.sassma... at ucl.ac.uk
Wed Nov 2 16:08:43 CET 2016


Dear all,

I am aware that this might be a bit the wrong list to ask but as cp2k is using 
QUIP I got a bit of hope that somebody might be able to help me here.

I am currently in the process of installing the latest version of cp2k (3.0) 
and I struggle a bit to get QUIP compiled. 
As I am doing an installation for the whole of the University I thought it 
would be good to get as much additional features installed into cp2k as 
possible. This is particularly true as a user told me that the installation I 
am doing is what they need. 

I have installed kim-api-v1.7.3 without any problems and I have downloaded the 
latest version of QUIP from git-hub.

During the configuration of quip I do the following:

Please enter directory where the OpenKIM library is kept:
   Default: no OpenKIM support
/usr/local/kim-api-v1.7.3/lib


This is where the progam (KIM) is installed but this is not where it was 
build. 

If I then try to build quip I get:

$ make 
[ ... ] 
make -C /usr/local/src/quip/QUIP/build/linux_x86_64_gfortran 
QUIP_ROOT=/usr/local/src/quip/QUIP 
VPATH=/usr/local/src/quip/QUIP/src/Potentials -I/usr/local/src/quip/QUIP -
I/usr/local/src/quip/QUIP/arch
make[1]: Entering directory 
'/usr/local/src/quip/QUIP/build/linux_x86_64_gfortran'
gfortran  -x f95-cpp-input -ffree-line-length-none -ffree-form -fno-second-
underscore -fPIC -I/usr/local/src/quip/QUIP/src/libAtoms -
I/usr/local/src/quip/QUIP/src/fox/objs.linux_x86_64_gfortran/finclude -
I/usr/include `kim-api-v1-build-config --includes` -O3  -DGETARG_F2003 -
DGETENV_F2003 -DGFORTRAN -DFORTRAN_UNDERSCORE -
D'GIT_VERSION="https://github.com/libAtoms/QUIP.git,aa2ab37-dirty"' -
D'GAP_VERSION=1469201250' -D'QUIP_ARCH="linux_x86_64_gfortran"' -
D'SIZEOF_FORTRAN_T=2' -DHAVE_NETCDF -DNETCDF4 -DHAVE_KIM -DHAVE_PRECON -
DHAVE_QR -DHAVE_CP2K  -c  
/usr/local/src/quip/QUIP/src/Potentials/IPModel_KIM.f95 -o IPModel_KIM.o
/usr/local/src/quip/QUIP/src/Potentials/IPModel_KIM.f95:59.4:

use KIM_API
    1
Fatal Error: Can't open module file 'kim_api.mod' for reading at (1): No such 
file or directory
Makefile.rules:182: recipe for target 'IPModel_KIM.o' failed
make[1]: *** [IPModel_KIM.o] Error 1
make[1]: Leaving directory 
'/usr/local/src/quip/QUIP/build/linux_x86_64_gfortran'
Makefile:125: recipe for target 'Potentials' failed
make: *** [Potentials] Error 2


I was searching for kim_api.mod in both the kim source and the installed 
directory but I could not find it. 

Would somebody be so kind and point me in the right direction here? We can do 
that off-list if necessary.

Thanks for your help.

Regards

Jörg

-- 
*************************************************************
Dr. Jörg Saßmannshausen, MRSC
University College London
Department of Chemistry
20 Gordon Street
London
WC1H 0AJ 

email: j.sassma... at ucl.ac.uk
web: http://sassy.formativ.net

Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 220 bytes
Desc: This is a digitally signed message part.
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20161102/c22c6049/attachment.sig>


More information about the CP2K-user mailing list