[CP2K:7630] Re: libint2 cp2k-3

Drahomir Chovan draho... at gmail.com
Tue Mar 29 14:54:05 UTC 2016

than you Sergey for mention about silent ignoring the flags. I will compile
with libint 1.1.5 (1.1.4 resp) and will get back to you how i am getting
on. The usage of XC functionals and HF exchange is crucial for me at the
moment. I want to do mixed QM/MM calcs and also have a project I need to
use HF so that's why I was bit in rush having this compiled properly. and
yes, just checked the compilation logs and the error was indeed libxc not


On 29 March 2016 at 14:50, Sergey Chulkov <sergeya... at gmail.com> wrote:

> Dear Drahomir,
> the source code depends on the flag -D__LIBINT, not -D__LIBINT2. All
> unknown macro definitions are silently ignored, that is why your version of
> cp2k has been compiled without libint support.
> The error message you mentioned probably reads: "This version of CP2K ONLY
> works with libxc versions 2.2.2 and above" and is related to a different
> library (libxc, not libint). If you use the flag -D__LIBXC2 in your arch
> file please ensure that you provided correct path to the libxc headers as
> well. By the way, you can simply omit this flag if you do not plan to use
> the &LIBXC subsection of the section &XC_FUNCTIONAL.
> Best wishes,
> Sergey.
> On Tuesday, March 29, 2016 at 12:41:13 PM UTC+1, drahomirko wrote:
>> Thank you for reply Sergey,
>> I used D__LIBINT2 flag and paths to headers and static libs. I also tried
>> D_LIBINT and libint version 1 but the compilation was aborted with
>> something like: "this version only supports libint2" and D__LIBINT2 with
>> libint v1 gave me wrapper error. As I mentioned in earlier post, there has
>> been no error message during compilation with libint2.  I saw the posts
>> here regarding wrapper problem, but didn't think it was my case since
>> compilation was OK.
>> any hints?
>> Drahomir
>> On Tuesday, 29 March 2016 09:40:12 UTC+1, drahomirko wrote:
>>> Hi,
>>> I compiled cp2k-3.0 no problem at all. calcs are running fine, all good.
>>> the problem occurs when I try to run HF calcs - segfault. when I ran test,
>>> all except HF passed. the error message reads that libint not found. before
>>> anyone asks, all flags and paths were set correctly.
>>> I'd appreciate if someone can help me out with this coz after a week
>>> trying to have it working I am scratching walls now.
>>> Thanx a mil.
>>> Drahomir
>> --
> You received this message because you are subscribed to a topic in the
> Google Groups "cp2k" group.
> To unsubscribe from this topic, visit
> https://groups.google.com/d/topic/cp2k/9jCT6-EhF54/unsubscribe.
> To unsubscribe from this group and all its topics, send an email to
> cp2k+uns... at googlegroups.com.
> To post to this group, send email to cp... at googlegroups.com.
> Visit this group at https://groups.google.com/group/cp2k.
> For more options, visit https://groups.google.com/d/optout.

Drahomir Chovan

*http://www.linkedin.com/in/dchovan* <http://www.linkedin.com/in/dchovan>

"*The success or failure of your deeds does not add up to the sum of your
life. The spirit cannot be weighed. Judge yourself by the intentions of
your actions, and by the strength with which yo**u faced the challenges
that have stood in your way. The Universe is vast and we are so small.
There is really only one thing we can ever truly control... whether we are
good or evil."*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20160329/c636c855/attachment.htm>

More information about the CP2K-user mailing list