[CP2K:6632] Re: Compilations with Intel (XE 2013) for CP2K-trunk (2.7dev) & regtests errors

Rolf David rolf.d... at gmail.com
Mon Jun 15 11:08:36 UTC 2015

Hi again,

The 'workaround' proposed by Alfio

> cat no.wlm
> batch_cmd() {
> $@
> }
> Therefore you can use "-j 100 -w no".
> Note that I have never tried such a case, so I'm not sure it will work 
> out-of-the-box. Let me how it goes.

worked well in my case. I was able to compile. And run tiny1 all of it. And 
tiny2 in standard after.

I'm moving on onto small1.

Also I've compiled libgrid (on a compute node) and successfully integrated 
into CP2K. Is there a "benchmark" to see the effect, I mean a file in the 
tests-folder where people get difference without and with libgrid ?
I run H2O-512.inp, but not noticeable difference. I run a test I had (QM/MM 
with hybrid functional) and I didn't see noticeable effect (on short 
tests), and in the readme it said about "Gaussian to Plane wave 
transformations", so I assume a speed up in some routine in GPW (or even 
GAPW no ?)
Also, Iain said 
and here again, it's performance-critical.

So if I have a "working" benchmark, I can see if I miscompiled it (no error 
in the out of the libgrid compilation), or maybe wrong compiler option and 
subroutines affected:  integrate_v_rspace for example  ?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20150615/6c37df4a/attachment.htm>

More information about the CP2K-user mailing list