[CP2K:2376] Re: neither PGI nor Intel compiler working?

Ondrej Marsalek ondrej.... at gmail.com
Tue Nov 3 12:07:14 CET 2009


Hi Ilya,

running the full test suite, I got some problem in RT propagation
(that printed some warning indicating that they are expected to fail)
and a few problems in HFX, which I have not investigated yet.
Otherwise, it looks fine.

The arch file is attached. If you have any suggestions for further
tuning, please let me know.

Best,
Ondrej


On Tue, Nov 3, 2009 at 11:47, Ilya <ikupc... at gmail.com> wrote:
>
> Hello Ondrej.
>
> I have ifort 11.0, but I'm still getting Nan's in the output.
>
> Could you post your arch file used for 11.0.084, please.
>
> Thanks.
>
> Ilya
>
> On Oct 30, 12:33 am, Ondrej Marsalek <ondrej.... at gmail.com>
> wrote:
>> A quick update. Using the libint wrapper, I have compiled with
>> 11.0.084 and a quick test says that at least one of the previously
>> failing tests now does work.
>>
>> The question that now remains - is there any point in trying to get
>> 11.1.x working? Any experience?
>>
>> Ondrej
>>
>> On Thu, Oct 29, 2009 at 19:38, Ondrej Marsalek
>>
>> <ondrej.... at gmail.com> wrote:
>> > Hi,
>>
>> > this sounds promising. I would like to ask which version of the Intel
>> > compiler to use. The readme file for libint use lists 11.1.056 as
>> > having full ISO_C_BINDING support, so presumably it works. On the
>> > other hand, this page:
>>
>> >http://software.intel.com/en-us/articles/build-cp2k-using-intel-fortr...
>>
>> > says that 11.1 should not be used. I do realize that that information
>> > is from July, but it is still there.
>>
>> > Any suggestions appreciated,
>> > Ondrej
>>
>> > On Wed, Oct 28, 2009 at 16:21, Urban <bors... at pci.uzh.ch> wrote:
>>
>> >> There was a known issue that resulted in an error in
>> >> cp_fm_cholesky_decompose when run with certain processor numbers. That
>> >> issue, along with the Intel compiler issues, should have been fixed
>> >> with the commits of Oct. 27.
>>
>> >> On Oct 26, 4:46 pm, NUCP2K <chenh... at gmail.com> wrote:
>> >>> Dear cp2k community,
>>
>> >>>   I just downloaded the latest CVS snapshot and tried to compile the
>> >>> codes using my once working ARCH files for PGI and Intel compilers on
>> >>> Linux-x86-64 MPI machines. Unfortunately, none of the two compilers is
>> >>> working though both can get the codes compiled successfully. It seems
>> >>> to me that the "cp_fm_cholesky_decompose" is the cause of the runtime
>> >>> trouble since my testing job always exit abnormally when the
>> >>> subroutine is called.
>>
>> >>>   Anyone has the experience on successfully compiling and running the
>> >>> latest cp2k code on Linux PC MPI clusters? The sharing of your ARCH
>> >>> files is highly appreciated.
>>
>> >>>   Thanks.
>>
>> >>> Hanning
> >
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Linux-x86-64-intel.popt
Type: application/octet-stream
Size: 1195 bytes
Desc: not available
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20091103/e1bb89b3/attachment.obj>


More information about the CP2K-user mailing list