Note: cp2k now requires an MPI-2 implementation.

Axel akoh... at gmail.com
Fri May 22 03:12:16 CEST 2009


hi everybody,

just a note to those that may be confused by running into compilation
problems after updating to the latest sources. with the changes
introduced
on may 12th the cp2k code now requires the MPI-2 style one sided
communication API to be present. many MPI installations are already
MPI-2 compliant, but quite a few are not. OpenMPI-1.x and MPICH2,
MVAPICH2 should work. for others, you should check. i just ran into
this issue while helping to solve somebody else's compilation problem
(which i could not reproduce with my installation, which is OpenMPI
based).

cheers,
     axel.


More information about the CP2K-user mailing list