[CP2K:1604] Re: output problems

Jun Cheng chen... at googlemail.com
Fri Dec 5 11:32:04 CET 2008


Hi Teo,

Thanks a lot for the help. It works well except the third individual output
file is still empty even with applying FLUSH_SHOULD_FLUSH TRUE. It is
probably because the third force_eva section is just a classic restraint to
a bond to prevent it from breaking during MD runs. So its output may be too
small to reach the size of the IO buffer in a noticeable time. In fact, I
did similar runs before and never got this output in 12 hours (the walltime
limit). Is there a way to overcome this problem?

Cheers,
Jun


On Thu, Dec 4, 2008 at 8:51 PM, Laino Teodoro <teodor... at gmail.com>wrote:

> Dear Jun,
> 1) you don't see nothing in the individual .out files because the IO is
> buffered.
> Depending on the size of the IO buffer on the machine that you are using it
> may take a WHILE
> to see something in the output file.
> If you want to flush you can play with this keyword:
>
> http://cp2k.berlios.de/manual/CP2K_INPUT/GLOBAL.html#desc_FLUSH_SHOULD_FLUSH
>
> 2) Switching to medium you are activating some print_key, in this case
> DIPOLE, which for the
> specific force_eval you are using (MIXED) requires that DIPOLE has to be
> defined in all
> force_eval underneath. To skip this problem you can disable by hand the
> print_key DIPOLE:
> http://cp2k.berlios.de/manual/CP2K_INPUT/FORCE_EVAL/MIXED/PRINT/DIPOLE.html
>
> .....
>     &DIPOLE OFF
>     &END
> .....
>
> This will solve your issue.
> Teo
>
> On 4 Dec 2008, at 19:15, Jun Cheng wrote:
>
> Hi Teo,
>
> I am very sorry about this.
> The file (test.tgz) is uploaded in group files.
> Thanks.
>
> Jun
>
> On Thu, Dec 4, 2008 at 6:00 PM, Teodoro Laino <teodor... at gmail.com>wrote:
>
>>
>> and where is your input file?
>> What you describe has not too much sense..anyway..
>> Provide your input file and all files necessary to investigate the
>> problem (i.e. run it).
>> This is a general rule when asking for help, and I'm surprised to see
>> that one has always to remind that.
>> Teo
>>
>> Jun wrote:
>> > Hi all,
>> >
>> > I updated my cp2k yesterday, and did some tests on mixed multi
>> > force_eva calcuations. I've got some problems on the outputs:
>> > (i) When I used print_level low, the job got running. Everything
>> > looked fine except for the empty output files corresponding to the
>> > individual force_eva.(the overall output file, *ener file and *xyz
>> > were fine).
>> > (ii) Then, I tried print_low medium. I got the individual output
>> > files, but the job stopped after initialization. The error message
>> > is:
>> > =============================================================
>> >  THERMOSTAT| Thermostat Info for PARTICLES
>> >  THERMOSTAT| Type of thermostat                               Nose-
>> > Hoover-Chains
>> >  THERMOSTAT| Nose-Hoover-Chain
>> > length                                          3
>> >  THERMOSTAT| Nose-Hoover-Chain time constant
>> > [  fs]                      1000.00
>> >  THERMOSTAT| Order of Yoshida
>> > integrator                                       3
>> >  THERMOSTAT| Number of multiple time
>> > steps                                     2
>> >  THERMOSTAT| Initial Potential
>> > Energy                                   0.000000
>> >  THERMOSTAT| Initial Kinetic
>> > Energy                                     0.000523
>> >  THERMOSTAT| End of Thermostat Info for PARTICLES
>> >
>> >  ********************** begin of velocity initialization
>> > ***********************
>> >  Initial
>> > Temperature                                                    330.00
>> > K
>> >  COM velocity:            0.000000000000      0.000000000000
>> > 0.000000000000
>> >  *********************** end of velocity initialization
>> > ************************
>> >
>> >
>> >  *** 17:07:15 WARNING in force_env_methods:mixed_energy_forces
>> > err=-300   ***
>> >  *** ASSERTION (cond) failed at line   1203 Error (0.259964E-11)
>> > in       ***
>> >  *** computing numerical derivatives larger then
>> > (0.100000E-11) .          ***
>> >  *
>> >  *** 17:07:15 ERRORL2 in cp_result_methods:get_result_r1
>> > processor      0   ***
>> >  *** err=-300   Trying to access result ([DIPOLE]) which was never
>> > stored!  ***
>> >  *** /home/e89/e89/jc590/work/cp2k/makefiles/../src/
>> > cp_result_methods.F     ***
>> >  *** line
>> > 164                                                            ***
>> >  *
>> >
>> >  ===== Routine Calling Stack =====
>> >
>> >             2 qs_mol_dyn_low
>> >             1 CP2K
>> >  CP2K|  Trying to access result ([DIPOLE]) which was never stored! /
>> > home/e89/e89/jc590/work/cp2k/makefiles/../src/cp_result_methods.F
>> > line    164
>> >  CP2K| Abnormal program termination, stopped by process number 0
>> >  CP2K|  Trying to access result ([DIPOLE]) which was never stored! /
>> > home/e89/e89/jc590/work/cp2k/makefiles/../src/cp_result_methods.F
>> > line    164
>> >  CP2K|  Trying to access result ([DIPOLE]) which was never stored! /
>> > home/e89/e89/jc590/work/cp2k/makefiles/../src/cp_result_methods.F
>> > line    164
>> >  CP2K| Abnormal program termination, stopped by process number 65
>> >  CP2K| Abnormal program termination, stopped by process number 64
>> >  CP2K|  Trying to access result ([DIPOLE]) which was never stored! /
>> > home/e89/e89/jc590/work/cp2k/makefiles/../src/cp_result_methods.F
>> > line    164
>> >  CP2K| Abnormal program termination, stopped by process number 14
>> > ===================================================================
>> >
>> > Does anyone know what is the problem? Any reply will be appreciated.
>> >
>> > Cheers,
>> > Jun
>> >
>> > P.S. I will upload my inputs if necessary.
>> >
>> > >
>> >
>>
>>
>>
>>
>
>
>
>
>
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20081205/e1a95adc/attachment.html>


More information about the CP2K-user mailing list