&EXT_RESTART logic reversal
akoh... at gmail.com
Wed Sep 5 01:27:19 CEST 2007
On Sep 4, 1:30 am, Teodoro Laino <teodor... at gmail.com> wrote:
> Good point.. To me, what you propose, looks like a good compromise:
> add a RESTART_ALL (default .TRUE.)
> all other have default .FALSE.
if you implement it like this, i would rename
this flag to RESTART_DEFAULT as it determines
the default value for all other restart flags.
this would also indicate that this flag is evaluated
first and then the others. RESTART_ALL would make
more sense, if the default would be .false.
(ok, i'm nitpicking here, but you'll have to live
with the choice for a long time, so i think it is
worth thinking about what people would assume).
> In this way nothing changes for people that were used to restart all
> keywords and if
> one does not want to do that than need only set the RESTART_ALL
> to .FALSE. and activate
> the single ones explicitly..
> Negative comments? (if not I will proceed in this way..)
> On 4 Sep 2007, at 03:39, Axel wrote:
> > hi all!
> > when playing around with the &EXT_RESTART section over the last
> > weeks, i was wondering if it would not be more user-friendly to change
> > the default to not restart anything and then only restart those
> > properties
> > that are set to .true. explicitely in addition to a RESTART_ALL flag.
> > as it is now, one can get easily confused about what is being
> > restarted,
> > and if one only wants to restart a few sections, one has to first look
> > up
> > _all_ restartable properties (which also change over time) and set
> > them
> > all to .false.
> > what do you think?
> > cheers,
> > axel.
More information about the CP2K-user