[CP2K-user] [CP2K:17974] Re: Exec Format Error

Matt Watkins mattwatkinsuk at gmail.com
Tue Nov 1 15:48:56 UTC 2022

I can't directly help as this is not really a cp2k question. A quick look 
at the QMflows documentation didn't give me a recipe for getting cp2k 
working. Maybe someone here is involved in the QMflows package and can...?
I think you need to find or reach out the QMflows people and ask for help 
getting cp2k working with it. 
It is clear they are trying to support cp2k but not sure who is in touch 
with whom.
( https://qmflows-namd.readthedocs.io/en/latest/docs_cp2k_interface.html )

On Tuesday, 1 November 2022 at 15:17:46 UTC 15wh... at gmail.com wrote:

> Wondering if anyone has encountered this error before. I'm new to a 
> research project and trying to get some old code to work again in the 
> server. Basically I've installed miniconda, created a new environment into 
> which I've installed nano qmflows for python. Then I installed cp2k-7.1, I 
> installed it with the all packages selection so it should have installed 
> everything. I've made a ton of progress with getting towards a successful 
> execution but I've been stuck for a while now with a specific error: "Exec 
> Format Error"
> I run a batch script which initializes the environment, then runs the 
> python script, which imports nanoqm and runs the "derivative_coupling" 
> workflow. It takes an already generated .xyz file, schedules around 6000 
> points and then errors with about 300 repeats of the following line:
> slurmstepd: error: execve(): /${my_dir}/cp2k.popt: Exec format error
> I've tried all kinds of executables inside the cp2k-7.1/arch/ folder and 
> all of them return the same thing. Although it simultaneously tells me:
> There are no wave function file in path: '/${work_dir}/cp2k_job.006' with 
> a traceback of the python error.
> My understanding of exec format error is that there's a problem with the 
> script attempting to be run, the actual cp2k.psmp or popt or sopt file is 
> unable to be run. Has anyone encountered this before? Is there any advice 
> for solving this issue? There's quite a lot of pressure to get this working 
> and this is my first semester in the project. 
> Thanks for reading

You received this message because you are subscribed to the Google Groups "cp2k" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cp2k+unsubscribe at googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cp2k/2d11f023-ac2c-4560-8703-31efebc7fd47n%40googlegroups.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20221101/0a41f4d4/attachment-0001.htm>

More information about the CP2K-user mailing list