[CP2K-user] [CP2K:16735] Re: Error during install

Eric Ledieu eric.ledieu.science at gmail.com
Thu Mar 17 17:48:15 UTC 2022

Update: I tried using the mkl install flag, which informed me I was missing 
FFTW3-MPI libraries. I reinstalled fftw3 and enabled mpi compatibility to 
install the respective libraries. the install mkl flag still gave me the 
same error, which makes me think that it is not picking it up for some 
reason. I'll keep digging into it.


On Thursday, March 17, 2022 at 10:30:53 AM UTC-5 Eric Ledieu wrote:

> I think you may be onto something. it seems that I did not have an mkl 
> install (and apt-get did not find one to install by default). I am running 
> down dependencies and installing it now. I'll report the results back here 
> for anyone who runs into the same issue. thank you for the lead.
> -Eric
> On Thursday, March 17, 2022 at 2:23:11 AM UTC-5 abdullahb... at gmail.com 
> wrote:
>> I am not sure if this might help but compilation problems for me 
>> regarding elpa were resolved when i compiled the latest intel mkl libraries 
>> and then used --with-mkl=/dir/to/mkl with the toolchain script.
>> Abdullah
>> On Thursday, March 17, 2022 at 2:53:02 AM UTC+9 eric.ledi... at gmail.com 
>> wrote:
>>> oh and I am on 8.2
>>> On Wednesday, March 16, 2022 at 12:37:47 PM UTC-5 Eric Ledieu wrote:
>>>> Hello! sorry for the bother, but I am running into an error during 
>>>> install and I have no idea how to fix it. as elpa is a hard dependency, I 
>>>> figured simply marking it as to skip was not valid here is the error code I 
>>>> get. the log file is empty.
>>>> ERROR: (./scripts/stage5/install_elpa.sh, line 110) Non-zero exit code 
>>>> detected.
>>>> the input I used is ./install_cp2k_toolchain.sh --gpu-ver=V100 
>>>> --enable-cuda
>>>> any help/lead would be appreciated

You received this message because you are subscribed to the Google Groups "cp2k" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cp2k+unsubscribe at googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cp2k/a1ba1539-d5be-4b2b-980c-b15b1d1ea3efn%40googlegroups.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20220317/cf18dcbd/attachment-0001.htm>

More information about the CP2K-user mailing list