[CP2K-user] [CP2K:16674] CP2K-9.1 compiling and testing questions

Huan Wang hanks.h.wang at gmail.com
Mon Mar 7 04:27:15 UTC 2022

Dear CP2K developers and users,

I am new to the CP2K program. 
Recently, I tried to compile CP2K-9.1 on Ubuntu 20.04 LTS with gcc-11.2.0 
by using the toolchain. 

At first, I did everything as root. I decompressed the CP2K-9.1 in 
/opt/cp2k-9.1 directory. The compiling process was fine, however, I could 
not be able to run test with "make -j 16 ARCH=local VERSION=psmp test". I 
tried to add 


However, I was still unable to run the test as root. In addition, I was not 
allowed to run the test as a normal user due to "Permission denied" at /opt 

Then, I repeated the whole compiling process at ~/Public directory as a 
normal user. The compiling process was fine as well. But the when I 
preformed the test with "make -j 16 ARCH=local VERSION=psmp test", there 
were 51 "Time out" errors appearing at the end. I also checked the CPU 
consumption during the test. It is strange that I requested 16 cores, 
however, there were only 2 cores working.

Please see the attached Markdown file of the full records of the compiling 
and test with the file name of 
"cp2k-9.1_GNU_installation_info_and_test.md", and the screenshot of "htop".

My questions are:
1) How can I run the test as root or by using sudo?

2) Is there any "lock" when running "make -j 16 ARCH=local VERSION=psmp 
Since I tried to copy H2O-32.inp from benchmarks/QS/ directory to ~/test/ 
directory, it run well with 16 cores and even full cores on my workstation.

3) As far as I know, CP2K is extremely fastidious about the Intel 
compilers, as shown in the https://www.cp2k.org/dev:compiler_support link.
I am not sure if the "Intel classic 19.1.1" is the same as the 
"Intel parallel studio xe 2019 update1 cluster edition"?
Whether all versions of Intel oneAPI fail to compile CP2K?  

It would be greatly appreciated if any of you could provide suggestions.  

Best regards,


You received this message because you are subscribed to the Google Groups "cp2k" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cp2k+unsubscribe at googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cp2k/dde23637-d552-4ba1-816a-db81bf3bc597n%40googlegroups.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20220306/06fe87c5/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cp2k-9.1_GNU_installation_info_and_test.md
Type: text/markdown
Size: 90479 bytes
Desc: not available
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20220306/06fe87c5/attachment-0001.md>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: CP2K_test_CPU_consumptions.png
Type: image/png
Size: 128460 bytes
Desc: not available
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20220306/06fe87c5/attachment-0001.png>

More information about the CP2K-user mailing list