[CP2K-user] [CP2K:18239] CP2K regtest - Runtime Fail

Trevor Voss tvoss15 at gmail.com
Wed Dec 21 16:59:24 UTC 2022

Hello again everyone, 

First thing to note is that I am a total noob at all of this. This is my 
first time using Linux (luckily I have an expert to help me).

I am working to build CP2K on Ubuntu 22.04.1 LTS with an AMD Threadripper 
3970x and NVIDIA 3090Ti using MPI support with openmp. 

I have successfully compiled CP2K and am now running the regtest. I'll 
attach the error_summary and my arch file. I keep getting a timeout and it 
says "Runtime failure with code -11" for every fail. It says I have 143/198 
correct tests, and 55 failed. Yesterday it was out of 200, so that confuses 
me a bit too. 

I also cannot set the number of jobs using the -j flag. No matter what I 
set it to, the tests use all of my CPU cores. I've also tried using the 
--mpiranks flag and it just gives me an error saying that isn't a flag (but 
then suggests me using the exact same flag). Here are the inputs I have 
been using for that. 

make j 2 ARCH=minimal VERSION=sdbg test TESTOPTS+=”-mpiranks 2 -ompthreads 
2 -maxtasks 2”

make j 2 ARCH=minimal VERSION=sdbg test TESTOPTS+=”--mpiranks 2 
--ompthreads 2 --maxtasks 2”

I've also tried it with just the mpiranks flag. 

Lastly, I also tried using the -d and --debug flags to get more info to 
help fix my issues, but it seems like it didn't actually give me any extra 
info? Maybe I am just missing something. 

Any help on any of this would be greatly appreciated! Thanks for the help! 

You received this message because you are subscribed to the Google Groups "cp2k" group.
To unsubscribe from this group and stop receiving emails from it, send an email to cp2k+unsubscribe at googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/cp2k/ef8363e5-76e5-4ea1-92f1-f91e1423f45dn%40googlegroups.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20221221/2b9e3a17/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: minimal.sdbg
Type: application/octet-stream
Size: 1961 bytes
Desc: not available
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20221221/2b9e3a17/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: error_summary
Type: application/octet-stream
Size: 324716 bytes
Desc: not available
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20221221/2b9e3a17/attachment-0003.obj>

More information about the CP2K-user mailing list