[CP2K-user] “SIGSEGV: Segmentation fault” when running CP2K-7.1 ff_match

Gaoyong Liu liugao... at gmail.com
Fri Oct 23 07:32:28 UTC 2020


An error appeared when I do the task6 of the official examples 
The task6 is that fitted force field parameters. 

error details :
----------------- Dividing Line ------------------------------
 DBCSR| Multiplication size stacks                                          

 FORCE_MATCHING| good morning....

Program received signal SIGSEGV: Segmentation fault - invalid memory 

Backtrace for this error:
#0  0x2b3a14be8dfd in ???
#1  0x2b3a14be8013 in ???
#2  0x2b3a159f43ff in ???
#3  0xb4eaaa in force_matching
at /data/lgy_data/cp2k_compile/src/optimize_input.F:226
#4  0xb4eaaa in __optimize_input_MOD_run_optimize_input
at /data/lgy_data/cp2k_compile/src/optimize_input.F:146
#5  0x45eedc in cp2k_run
at /data/lgy_data/cp2k_compile/src/start/cp2k_runs.F:257
#6  0x4621cf in __cp2k_runs_MOD_run_input
at /data/lgy_data/cp2k_compile/src/start/cp2k_runs.F:965
#7  0x44f46f in cp2k
at /data/lgy_data/cp2k_compile/src/start/cp2k.F:296
#8  0x40893c in main
at /data/lgy_data/cp2k_compile/src/start/cp2k.F:45
[1]    24363 segmentation fault (core dumped)  cp2k.ssmp -i ff_match.in
----------------- Dividing Line ------------------------------

I have tried use other version to fix this error.

1. use ssmp version on github release 7.1    --------- same error
2. use ssmp version on github release 6.1    --------- same error
3. run "ulimit -s unlimited" mentioned by this 
<https://groups.google.com/g/cp2k/c/91_1kGYg55w/m/xK6gnpLCAgAJ>  ------- 
same error

If any help, thank you.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20201023/c28fa7bb/attachment.htm>

More information about the CP2K-user mailing list