[CP2K-user] [CP2K:13397] Re: Getting cp2k to work with ASE

Hasan Al-Mahayni hasanal... at gmail.com
Tue May 26 18:06:25 UTC 2020

Hi again,

So the path seems to be this


So i did this command, then i ran the python commands

export ASE_CP2K_COMMAND="mpirun -np 2 /cvmfs/

And it gave me the same error, so i did this:

export ASE_CP2K_COMMAND="mpirun -np 2 -mca btl ^openib /cvmfs/

And then the python commands, gives me the same error "Assertion error"...

On Tue, May 26, 2020 at 5:16 AM Maxime Van den Bossche <
maxime.cp.... at gmail.com> wrote:

> @Hasan: you need to replace "/path/to/cp2k_shell.popt" with the actual path
> to the cp2k_shell.popt executable on your (remote) machine. That path
> depends
> on how CP2K was installed. If you compiled CP2K yourself, just look in the
> "exe"
> directory of your main CP2K folder, as described here:
> https://www.cp2k.org/howto:compile
> If you didn't compile CP2K yourself, ask your system administrator.
> @Yuvam: ASE just provides a Python framework/interface; if you want GPU
> acceleration in CP2K you first need to compile with CUDA support:
> https://www.cp2k.org/howto:compile_with_cuda
> For GPU/CUDA-specific questions, however, better start a separate thread.
> --
> You received this message because you are subscribed to the Google Groups
> "cp2k" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to cp... at googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/cp2k/84ddc2bc-c096-40ce-8944-a666fb4cf229%40googlegroups.com
> <https://groups.google.com/d/msgid/cp2k/84ddc2bc-c096-40ce-8944-a666fb4cf229%40googlegroups.com?utm_medium=email&utm_source=footer>
> .
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20200526/be3c1368/attachment.htm>

More information about the CP2K-user mailing list