[CP2K-user] [CP2K:11784] Re: Compiling CP2K with AMD Libraries

Bich Phuong bichphu... at gmail.com
Thu May 23 09:36:38 UTC 2019

Hi Alfio,

Thank you for your answer.
The libflame is AMD lib having LAPACK functions. I actually linked libflame
together with blis before and still showed the same errors.
After reading your answer, I tried to link LAPACK + BLIS and eventually it
works although I haven't tested with benchmarks yet. I assume that there
are some problems with Libflame and I will try to compile it again.

I also appreciate your suggestion for libxsmm and libsmm. Actually we have
cp2k as a application task in a cluster competition.
Do you know any way to boost performance a bit without changing the given
input file?

On Thu, 23 May 2019 at 11:08, Alfio Lazzaro <alfio.... at gmail.com> wrote:

> Hello Bich Phuong,
> larnv is a LAPACK function. However, I don't see any LAPACK library in
> your arch file:
> LIBS        = -lblis -lxsmmf -lxsmm -ldl -lpthread -lsmm_dnn -lxcf03 -lxc
> -lderiv -lint -lfftw3 -lstdc++
> BTW, I see that you are lusing libxsmm and libsmm, there are mutual
> exclusive. You can just use libxsmm.
> Alfio
> Il giorno mercoledì 22 maggio 2019 20:58:20 UTC+2, Bich Phuong ha scritto:
>> Hello,
>> I like to compile CP2K with AMD libs to compare the performances with the
>> one compiled with OpenBLAS, LAPACK and Scalapack
>> since I had the system with 2 x EPYC 7601.
>> I checked the install_cp2k_toolchain.sh and install_acml.sh but the acml
>> doesn't exist anymore (https://developer.amd.com/amd-cpu-libraries/),
>> thus can not use this tool.
>> I modify the local.sopt (tried with sopt firstly) arch file created by
>> install_cp2k_toolchain.sh by replacing path of openblas and -lopenblas,
>> tried to link either BLIS/BLIS+libflame/LibM but nothing works (the
>> available libraries or compiled them by myself follow this documentation
>> https://developer.amd.com/wp-content/resources/AMDCPULibrariesUserGuide_1.3.pdf
>> ).
>> It complaint about undefined references to some BLAS functions.
>> -----------------------
>> /home/phuong/cp2k-6.1/lib/amd/sopt/libdbcsrops.a(dbcsr_operations.o): In
>> function `__dbcsr_operations_MOD_dbcsr_init_random':
>> /home/phuong/cp2k-6.1/src/dbcsr/ops/dbcsr_operations.F:1104: undefined
>> reference to `dlarnv_'
>> /home/phuong/cp2k-6.1/src/dbcsr/ops/dbcsr_operations.F:1104: undefined
>> reference to `dlarnv_'
>> /home/phuong/cp2k-6.1/lib/amd/sopt/libdbcsrops.a(dbcsr_blas_operations.o):
>> In function `__dbcsr_blas_operations_MOD_dbcsr_lapack_larnv':
>> /home/phuong/cp2k-6.1/src/dbcsr/ops/dbcsr_blas_operations.F:84: undefined
>> reference to `zlarnv_'
>> /home/phuong/cp2k-6.1/src/dbcsr/ops/dbcsr_blas_operations.F:82: undefined
>> reference to `clarnv_'
>> /home/phuong/cp2k-6.1/src/dbcsr/ops/dbcsr_blas_operations.F:78: undefined
>> reference to `slarnv_'
>> /home/phuong/cp2k-6.1/src/dbcsr/ops/dbcsr_blas_operations.F:80: undefined
>> reference to `dlarnv_'
>> collect2: error: ld returned 1 exit status
>> make[3]: *** [/home/phuong/cp2k-6.1/exe/amd/dbcsr_example_3.sopt] Error 1
>> make[3]: *** Waiting for unfinished jobs....
>> --------------------------
>> Does anyone have experiences with this work?
>> Which AMD library should I use to alter the ACML one?
>> Thank you.
> --
> You received this message because you are subscribed to a topic in the
> Google Groups "cp2k" group.
> To unsubscribe from this topic, visit
> https://groups.google.com/d/topic/cp2k/4vFftwwDEJg/unsubscribe.
> To unsubscribe from this group and all its topics, send an email to
> cp... at googlegroups.com.
> To post to this group, send email to cp... at googlegroups.com.
> Visit this group at https://groups.google.com/group/cp2k.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/cp2k/add016e6-b3a7-48f5-8dd9-d38eb9b50330%40googlegroups.com
> <https://groups.google.com/d/msgid/cp2k/add016e6-b3a7-48f5-8dd9-d38eb9b50330%40googlegroups.com?utm_medium=email&utm_source=footer>
> .
> For more options, visit https://groups.google.com/d/optout.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20190523/c2fa5013/attachment.htm>

More information about the CP2K-user mailing list