[CP2K-user] single test fails for ssmp

Thomas Danckaert thomas.d... at gmail.com
Mon Mar 25 10:32:20 UTC 2019


I've compiled CP2K from the master branch using the Intel Fortran compiler 
and MKL (arch file attached, it's a slightly modified version of the 
Linux-x86-64-intel.ssmp file from the CP2K repository).  When I run the 
regression tests for all four versions (popt, psmp, sopt and ssmp), only 
one test fails, and only for the ssmp version: 
tests/QMMM/QS/regtest-4/acn-conn-1.inp.  Does anyone have a suggestion what 
might cause this problem (wrong version of one of the dependencies?).

Unless I run with OMP_NUM_THREADS=1, the test fails with a segmentation 
fault, e.g.:

forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image              PC                Routine            Line        Source
cp2k.ssmp          0000000009F2674D  Unknown               Unknown  Unknown
libpthread-2.17.s  00007FD5418655D0  Unknown               Unknown  Unknown
cp2k.ssmp          00000000009E433F  cp_dbcsr_operatio         297  
libiomp5.so        00007FD54125C7D3  __kmp_invoke_micr     Unknown  Unknown
libiomp5.so        00007FD54122354A  Unknown               Unknown  Unknown
libiomp5.so        00007FD541222C0B  Unknown               Unknown  Unknown
libiomp5.so        00007FD54125CC30  Unknown               Unknown  Unknown
libpthread-2.17.s  00007FD54185DDD5  Unknown               Unknown  Unknown
libc-2.17.so       00007FD540EA9EAD  clone                 Unknown  Unknown

I'm using the following versions of compilers and libraries:

ifort: 18.0.3 20180410
MKL: 2018.3.222

libxc: 4.3.4
libint: 1.1.6
libxsmm: 1.8.3
(ELPA: 2017.05.003, but that is not relevant for the ssmp executable?)

Thank you for any advice!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20190325/e14d5adc/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Linux-x86-64-intel.ssmp
Type: application/octet-stream
Size: 1386 bytes
Desc: not available
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20190325/e14d5adc/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: acn-conn-1.out
Type: application/octet-stream
Size: 220172 bytes
Desc: not available
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20190325/e14d5adc/attachment-0001.obj>

More information about the CP2K-user mailing list