[CP2K-user] [CP2K:11994] Problems installing CP2K using libint-v2.5.0-cp2k-lmax-4

Jerry Tanoury jerryt... at gmail.com
Mon Jul 29 00:51:37 UTC 2019

Solved the problem.  During the libint build, the fortran mod file was not
being copied to the include directory.  I manually copied it there and no
libint errors were observed.


On Thu, Jul 25, 2019 at 12:13 PM Jerry Tanoury <jerryt... at gmail.com>

> Dear Forum,
> I am trying to compile the latest git version of CP2K which passes all
> test in Linux-x86-64-intel.popt (V19.0.3.199) dashboard.  However, I am
> having problems with libint-v2.5.0-cp2k-lmax-4, which worked successfully
> according to the dashboard results.  CP2K and all other supporting codes
> were compiled with Intel version 19.0.3. Here's what I did:
> 1.  Compiled libint-v2.5.0-cp2k-lmax-4 with: ./configure
> --prefix=/cluster/home/tanoury/CP2K/7x/intelbuilt_packages/libint-v2.5.0-cp2k-lmax-4
> --enable-eri=1 --with-cxx="icpc -g1" --with-cxx-optflags=-g1
> --enable-fortran --with-fc=ifort
> --libdir=/cluster/home/tanoury/CP2K/7x/intelbuilt_packages/libint-v2.5.0-cp2k-lmax-4/lib.
> (configure did not recognize "--enable-eri")
> 2.  When I ran 'make install', I got a few error messages (see attached
> "libint_error_makeinstall" file).
> 3.  Compiled libxsmm and libxc-4.3.4 successfully
> 4.  During my build of CP2K, and got the libint-related error messages:
> see "CP2K_build_errors" file.
> I have also attached the arch file I used.
> Any help is greatly appreciated.
> Thank you and best regards,
> Jerry
> --
> You received this message because you are subscribed to the Google Groups
> "cp2k" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to cp... at googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/cp2k/32a97b33-aaba-42bd-b02f-3c8ddd274e40%40googlegroups.com
> <https://groups.google.com/d/msgid/cp2k/32a97b33-aaba-42bd-b02f-3c8ddd274e40%40googlegroups.com?utm_medium=email&utm_source=footer>
> .
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20190728/375d535f/attachment.htm>

More information about the CP2K-user mailing list