Anton Kudelin archm... at gmail.com
Sat May 19 11:36:38 UTC 2018

Hi all,

I run Arch Linux, and recently it changed the major version of the system 
compiler. So I tried to compile CP2K with GCC 8.1.0 after the environment 
being rebuilt and found something strange. The problem may lay far beyond 
CP2K, but the program is a reliable indicator of the quality of compilers 
and libraries, by the way it has very experienced community.

In short, BLAS/LAPACK routines don't working when compiled with GCC 8.1.0. 
I tried NetLib BLAS/LAPACK, ATLAS, and OpenBLAS and obtained the same 
results: SCF cannot get converged. On the other hand, Intel MKL does things 
as earlier.

Could anybody check my results? If I get them proved, it could mean a 
terrible issue with GCC 8.1.0 or even with BLAS/LAPACK that has to be 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20180519/53b7769e/attachment.htm>

More information about the CP2K-user mailing list