installation of cp2k on linux mint machine

SS shya... at gmail.com
Thu Aug 30 07:03:31 CEST 2018


Hello thank you for your reply

I am just posting last portion of make.log file

/home/shyam/WORK/shyam/softwares/cp2k-5.1/tools/toolchain/install/binutils-2.28/bin/ld: 
cannot find -lz
collect2: error: ld returned 1 exit status
Makefile:2911: recipe for target 'dummysizes' failed
make[2]: *** [dummysizes] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory 
'/home/shyam/WORK/shyam/softwares/cp2k-5.1/tools/toolchain/build/scotch_6.0.0/src/libscotch'
Makefile:55: recipe for target 'scotch' failed
make[1]: *** [scotch] Error 2
make[1]: Leaving directory 
'/home/shyam/WORK/shyam/softwares/cp2k-5.1/tools/toolchain/build/scotch_6.0.0/src/libscotch'
Makefile:93: recipe for target 'scotch' failed
make: *** [scotch] Error 2
I am unable to figure out what is the problem?Which library is missing. 


On Wednesday, August 29, 2018 at 4:50:46 PM UTC+5:30, Matt W wrote:
>
> Hello,
>
> you will need to look in the build/scotch_6.0.0/src directory for the 
> make.log file from ptscotch to see what the real error message is. 
>
> It is likely a preprossessing library that is not preinstalled in mint.
>
> Matt
>
> On Wednesday, August 29, 2018 at 12:05:52 PM UTC+1, SS wrote:
>>
>> I was trying to install cp2k on my linux mint OS. I downloaded the cp2k 
>> file and prerequisites files from cp2k website and followed the instruction 
>> given in readme file after unzipping the cp2k files.When i tried to install 
>> the toolchain using 
>>
>> ./install_cp2k_toolchain.sh --install-all
>> it was showing an error message as follows
>>
>> Installing from scratch into /home/shyam/WORK/shyam/softwares/cp2k-5.1/tools/toolchain/install/scotch-6.0.0
>> ERROR: (/home/shyam/WORK/shyam/softwares/cp2k-5.1/tools/toolchain/scripts/install_ptscotch.sh, line 43) Non-zero exit code detected.
>>
>> I have all tar.gz files. I tried to install this from individual scotch_6.0.0.tar.gz file and it was not working
>>
>> I am new to the software and it would be helpful if someone can give a step by step installation guide.
>>
>> Thank you
>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20180829/225b8f2d/attachment.html>


More information about the CP2K-user mailing list