LIBXC installation

Megha Anand meghaan... at gmail.com
Fri Sep 9 21:42:50 CEST 2016


Dear All,

I would like to use M06 functional for my system comprising of Fe and S. I 
got an error after including FUNCTIONAL XC_HYB_MGGA_XC_M06

    

 *** In order to use libxc you need to download and install it ***


As per the instructions in the INSTALL file in /share/apps/cp2k/cp2k folder:


2k) Library of exchange-correlation functionals libxc (optional, v2.0.1):

     * The version 2.0.1 (ONLY this one) of libxc needs to be downloaded

       (http://www.tddft.org/programs/octopus/wiki/index.php/Libxc) and 
installed.

       During the installation, the directory $(LIBXC_DIR)/lib is created.

     * Add -D__LIBXC2 to DFLAGS and -L$(LIBXC_DIR)/lib -lxc to LIBS.


 I downloaded and installed libxc-2.0.1 in my home directory: 
/home/megha/libxc-2.0.1 and the file /home/megha/libxc-2.0.1/lib has been 
added. My question is in which file do I find the DFLAGS option to add 
-D__LIBXC2 and the other one. 


Someone please help.


Thanks,

Megha
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20160909/d8d46927/attachment.html>


More information about the CP2K-user mailing list