Error compiling CP2K 2.6 with GFortran 4.8.4

DEC014 dcoss... at
Tue Mar 1 18:48:18 UTC 2016

Hi Ole,

I figured out the problem.  It seems the SGI MPT mpicc and mpifort wrappers 
do not function as expected.  If I manually linked the libraries and 
include files, I was able to build CP2K without any issues.  Thank you for 
all the help.

David Cossey

On Wednesday, February 17, 2016 at 7:10:16 AM UTC-5, Ole Schütt wrote:
> Hi David,
> could you once paste the particular command line, ie. invocation of 
> gfortran, that that triggers to the error?
> -Ole
> Am Dienstag, 16. Februar 2016 21:56:12 UTC+1 schrieb DEC014:
>> It's a typical SGI ICE X HPC system.  We are using Make 3.81 with GCC 
>> 4.8.4.  I've also tried using GCC 4.7.3 to no avail.  My default shell is 
>> Bash.  I thought I solved this problem a couple months ago, as I did not 
>> respond to your earlier question; however, I went to compile CP2K v3.0 and 
>> I'm now running into the error again.  I have CP2K v2.6.1 installed and I 
>> copied my ARCH file over directly from the older version.  I'm not sure how 
>> I solved the problem before to complete the compilation.
>> -David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the CP2K-user mailing list