CP2K Hangs

Manav Kumar mk3... at nyu.edu
Fri Apr 24 21:08:52 UTC 2015

Hi Matt,

Thank you for your response!

I'm sorry I mis-spoke earlier, I meant to say that NVT not NVE that's my 
mistake. When I ran NVT with CP2K module it worked fine.

I ran a cell optimization using the CP2K module, and it went through fine.

I have talked to some of the other members in my group, and they mentioned 
that it is possible that when I am running the simulation on multiple nodes 
that one of them is faulty and therefore causing the calculations to hang. 
However, it seems like the probability of me hitting the same faulty node 
every time I submit a job seems highly unlikely. Also, if this was the case 
then wouldn't the jobs that I submit using my own compiled version of CP2K 
also hang?

When you said that the it was a problem with the cell size, what did you 
mean exactly?

Manav Kumar

On Friday, April 24, 2015 at 11:51:29 AM UTC-4, Matt W wrote:
> Hi,
> nothing is obviously wrong with your input that I can see. Maybe (i) 
> problem with the executable (ii) problem with cell size.
> To start debugging -
> You say you can run NVE - can you run NVT as you've got it set up?
> Can you run a cell optimization, maybe just a few steps, to check that the 
> stress tensor/cell volume change is working OK.
> Matt
> On Friday, April 24, 2015 at 12:52:48 PM UTC+1, Manav Kumar wrote:
>> Hi users and developers,
>> This is my first project using CP2K, so I'm sorry in advance if some of 
>> the things I say might be wrong.
>> I am currently trying to generate a trajectory for a simulation of 
>> diacetone diperoxide (DADP) using a NPT ensemble. I am attaching the input 
>> file, and the submit script below.
>> The HPC that I am using has a CP2K module. I performed a wave-function 
>> optimization, geometry optimization, cell optimization, and a NVE ensemble 
>> calculation all using the module. However, now that I am running the NPT 
>> calculation using the module it seems to hang. It reads in all the 
>> parameters from a previous restart file, it starts to initiate the process 
>> but gets stuck in the SCF optimization routine. It doesn't print an error 
>> message, it just stays at that position until the wall time comes along and 
>> kills the process. Sometimes it completes a lot of SCF optimization steps, 
>> sometimes it gets through none.
>> What I've done so far to try to remedy the problem is that I've tried 
>> compiling CP2K myself and running the calculation using that executable 
>> instead of the module. I've had a bit more success with my own compiled 
>> executable, but even with that it sometimes hangs. The system 
>> administrators responsible for the HPC checked the binaries and said that 
>> everything was fine.
>> Has anyone else had an issue similar to this?
>> Best,
>> Manav Kumar
>> I will attach my input file, output file, and submit script below so that 
>> you can see what I have been doing.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20150424/d78daeda/attachment.htm>

More information about the CP2K-user mailing list