any known issues for cp2k/2.4 with Openmpi 1.6.5?

cristia... at gmail.com cristia... at gmail.com
Fri Sep 27 15:16:41 CEST 2013


Hi all,

I've succesfully compiled cp2k.popt with intel openmpi/1.6.5, mkl/11.0.1, 
libint/1.1.4 

my arch file (Linux-x86-64-intel.popt):


INTEL_LIB = $(INTEL_MKL)/lib/intel64
INTEL_INC = -I$(INTEL_MKL)/include -I$(INTEL_MKL)/include/fftw
INTEL_SCALAPACK = -L$(INTEL_LIB) -lmkl_scalapack_lp64 
-lmkl_blacs_openmpi_lp64 -lmkl_intel_lp64 -lmkl_sequential -lmkl_core

LIBINT_PATH = <my_path to libint-1.1.4>
LIBINT_LIB  = <my_path to 
cp2k-2.4.0>/tools/hfx_tools/libint_tools/libint_cpp_wrapper.o 
$(LIBINT_PATH)/lib/libderiv.a $(LIBINT_PATH)/lib/libint.a -lstdc++


CC       = icc
CPP      =
FC       = mpif90
LD       = mpif90
AR       = ar -r
DFLAGS   = -D__HAS_NO_ISO_C_BINDING -D__INTEL -D__FFTSG -D__parallel 
-D__BLACS -D__SCALAPACK -D__FFTW3 -D__LIBINT -D__FFTMKL
CPPFLAGS = -C -traditional $(DFLAGS) -I$(INTEL_INC)
FCFLAGS  = $(DFLAGS) -I$(INTEL_INC) -O1 -heap-arrays 64 -fpp -free
FCFLAGS2 = $(DFLAGS) -I$(INTEL_INC) -O1 -heap-arrays 64 -fpp -free
LDFLAGS  = $(FCFLAGS)
LIBS     = -L$(INTEL_LIB) -mkl $(LIBINT_LIB) $(INTEL_SCALAPACK)

OBJECTS_ARCHITECTURE = machine_intel.o


graphcon.o: graphcon.F
        $(FC) -c $(FCFLAGS2) $<

but when I run my test with input file

&GLOBAL
  PROJECT test01
  RUN_TYPE MD
  PRINT_LEVEL LOW
&END GLOBAL
&FORCE_EVAL
  METHOD QS
  &DFT
    BASIS_SET_FILE_NAME ../../BASIS_MOLOPT
    POTENTIAL_FILE_NAME ../../GTH_POTENTIALS
    &MGRID
      CUTOFF 400
      NGRIDS 5
    &END MGRID
    &QS
    &END QS
    &SCF
      CHOLESKY OFF
      MAX_SCF 40
      SCF_GUESS ATOMIC
      &OT
        ENERGY_GAP 0.001
        MINIMIZER CG
        PRECONDITIONER FULL_ALL
      &END OT
      &OUTER_SCF ON
        EPS_SCF 1.0E-6
        MAX_SCF 10
      &END OUTER_SCF
      &PRINT
        &RESTART
        &END
        &RESTART_HISTORY
        &END
      &END PRINT
    &END SCF
    &XC
      &XC_FUNCTIONAL PBE
      &END XC_FUNCTIONAL
      &VDW_POTENTIAL
        POTENTIAL_TYPE PAIR_POTENTIAL
        &PAIR_POTENTIAL
           REFERENCE_FUNCTIONAL PBE
           PARAMETER_FILE_NAME my_parameter.dat
           TYPE DFTD3
           R_CUTOFF [angstrom] 30
        &END PAIR_POTENTIAL
     &END VDW_POTENTIAL
   &END XC
    &END DFT
   &SUBSYS
     &CELL
       ABC 16.826 16.136 30.0
     &END CELL
     &TOPOLOGY
       COORDINATE XYZ
       COORD_FILE_NAME ./test01_ini.xyz
       CONNECTIVITY OFF
     &END TOPOLOGY 
       ...
       ...
       ...
   &END SUBSYS
&END FORCE_EVAL
&MOTION
  &MD
    ENSEMBLE NVE
    STEPS 10000
    TIMESTEP 0.5
    TEMPERATURE 310.0
    TEMP_TOL 50.0
  &END MD
  &PRINT
    &RESTART
      &EACH
        MD 1
      &END
    &END
    &TRAJECTORY
      &EACH
        MD 1
      &END EACH
    &END TRAJECTORY
  &END PRINT
&END MOTION

cp2k.popt exit with:

 *************************************************************************
 *** 11:26:10 ERRORL2 in cp_dbcsr_cholesky:cp_dbcsr_cholesky_decompose ***
 *** processor 0  :: err=-300 condition FAILED at line 123             ***
 *************************************************************************


 ===== Routine Calling Stack =====

           11 cp_dbcsr_cholesky_decompose
           10 qs_ot_get_derivative
            9 ot_mini
            8 ot_scf_mini
            7 qs_scf_loop_do_ot
            6 scf_env_do_scf_inner_loop
            5 scf_env_do_scf
            4 qs_energies_scf
            3 qs_forces
            2 qs_mol_dyn_low
            1 CP2K

but the same run goes fine with a cp2k.popt compiled with intel 
openmpi/1.4.4, mkl/10.2.2, libint/1.1.4

does anyone know if cp2k/2.4 dosen't work fine with openmpi/1.6.5?
any suggestions?

thanks for help!!!!

Cristiano
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20130927/89a6a10b/attachment.html>


More information about the CP2K-user mailing list