ifort 12.1 bug?

Noam Bernstein no... at bollweevil.gdbg.org
Thu Sep 5 22:57:32 CEST 2013


I just tried to compile the latest svn version, and I ran across something
that I think is fair to say is an ifort 12.1 bug.  It doesn't like
parameter variables of derived types that are initialized object style, if
they have fields set to null and are constructed with some parameters
specified but not the ones set to null.  There's a patch below to get
dbcsr_types.F to compile working around this issue.

       Noam

Index: dbcsr_lib/dbcsr_types.F
===================================================================
--- dbcsr_lib/dbcsr_types.F (revision 13128)
+++ dbcsr_lib/dbcsr_types.F (working copy)
@@ -258,8 +258,8 @@
      TYPE(dbcsr_mempool_type), POINTER :: pool => Null()
   END TYPE dbcsr_memtype_type

-  TYPE(dbcsr_memtype_type), PARAMETER :: dbcsr_memtype_default =
dbcsr_memtype_type()
-  TYPE(dbcsr_memtype_type), PARAMETER :: dbcsr_memtype_MPI =
dbcsr_memtype_type(mpi=.TRUE.)
+  TYPE(dbcsr_memtype_type), PARAMETER :: dbcsr_memtype_default =
dbcsr_memtype_type(pool=Null())
+  TYPE(dbcsr_memtype_type), PARAMETER :: dbcsr_memtype_MPI =
dbcsr_memtype_type(mpi=.TRUE., pool=Null())

 !
*****************************************************************************
 !> \brief Stores actual data
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.cp2k.org/archives/cp2k-user/attachments/20130905/bca5e343/attachment.html>


More information about the CP2K-user mailing list