[CP2K:4276] CP2K intel MPI + intel/13.0.1.117 running problem

Ole Schütt o... at schuett.name
Mon Jan 28 20:32:14 CET 2013


Dear Guangrui,

this seems to be related to some recent code changes by myself.
I'll take a look at it tomorrow.

-Ole


Quoting Guanguri Qian <iqiang... at gmail.com>:

> HI, all
>
>     I have successfully compiled CP2K(12663) with Intel
> composer_x3_2013.1.117(also tried composer_xe_2011) + intel MPI 4.1.0.024 +
> intel MKL + intel FFT on E5 intel CPU. (I couldnt find openmpi in this
> cluster.)
>     But when i run the compiled cp2k.popt,  the code exit with error
> :"dict_i4tuple_callstat_change_capacity: assertion failed".
>
>     And I am sure about my input file. The input file works on another cp2k
> version(12507, compiled with openmpi 1.6.1 +
> Intel composer_xe_2011_sp1.10.319 + intel MKL & intel FFT on AMD cpu ).
>     Could anyone here give me some hints to solve this problem?
>     Thanks a lot.
>
>
> Guangrui Qian
>
> ***********************************************
>
> The Linux-x86-64-intel.popt file is attached below :
>
> ------------
> INTEL_MKL=/opt/apps/intel/13/composer_xe_2013.1.117/mkl/
> INTEL_INC=$(INTEL_MKL)/include/fftw
> INTEL_LIB=$(INTEL_MKL)/lib/intel64
> FFTW_LIB=/home/qian/Proc/fftw3xf/
>
> CC       = mpiicc
> CPP      =
> FC       = mpiifort
> LD       = mpiifort
> AR       = ar -r
> DFLAGS   = -D__INTEL -D__FFTSG -D__parallel -D__BLACS -D__SCALAPACK
> -D__FFTW3
> CPPFLAGS =
> #FCFLAGS  = $(DFLAGS) -I$(INTEL_INC) -O2 -xW -xhost -heap-arrays 64
> -funroll-loops -fpp -free
> #FCFLAGS2 = $(DFLAGS) -I$(INTEL_INC) -O1 -xW -heap-arrays 64 -fpp -free
> #LDFLAGS  = $(FCFLAGS) -I$(INTEL_INC)
>
>
> FCFLAGS  = $(DFLAGS)  -I$(INTEL_INC) -O2 -msse2 -heap-arrays 64
> -funroll-loops -fpp -free
> FCFLAGS2 = $(DFLAGS)  -I$(INTEL_INC) -O1 -msse2 -heap-arrays 64 -fpp -free
> LDFLAGS  = $(FCFLAGS) -I$(INTEL_INC)
>
> LIBS     = -L${FFTW_LIB} -lfftw3xf_intel \
> -L${INTEL_LIB} -I${INTEL_INC} -I${INTEL_INC}/intel64/lp64 -lmkl_blas95_lp64
> \
> -L${INTEL_LIB} -I${INTEL_INC} -I${INTEL_INC}/intel64/lp64
> -lmkl_lapack95_lp64 \
> ${INTEL_LIB}/libmkl_scalapack_lp64.a  -Wl,--start-group
> ${INTEL_LIB}/libmkl_intel_lp64.a ${INTEL_LIB}/libmkl_sequential.a
> ${INTEL_LIB}/libmkl_core.a ${INTEL_LIB}/libmkl_blacs_intelmpi_lp64.a
> -Wl,--end-group -lpthread
> -----------------------------------------
>
> --
> You received this message because you are subscribed to the Google  
> Groups "cp2k" group.
> To post to this group, send email to cp... at googlegroups.com.
> To unsubscribe from this group, send email to  
> cp2k+uns... at googlegroups.com.
> Visit this group at http://groups.google.com/group/cp2k?hl=en.
> For more options, visit https://groups.google.com/groups/opt_out.






More information about the CP2K-user mailing list