[CP2K:4069] gfortran-openMP probelm durigng the compilation

Iain Bethune ibet... at epcc.ed.ac.uk
Mon Oct 1 09:57:11 CEST 2012


Hi Davide,

ctrig.o is part of the FFT library within CP2K.  It should be compiled from the source file cp2k/src/fft_lib/ctrig.F - you should first check you have this file.  ctrig.o should get built automatically by the Makefile, so sounds like something went wrong in your build process.  Probably best is to start again:

make ARCH=Linux-x86-64-gfortran VERSION=psmp realclean

Hopefully this should fix the issue.  I have recently built CP2K with for this arch and it worked fine for me.

Cheers

- Iain

--

Iain Bethune
Applications Consultant, EPCC

Email: ibet... at epcc.ed.ac.uk
Twitter: @IainBethune
Web: http://www2.epcc.ed.ac.uk/~ibethune
Tel/Fax: +44 (0)131 650 5201/6555
Mob: +44 (0)7598317015
Addr: 2404 JCMB, The King's Buildings, Mayfield Road, Edinburgh, EH9 3JZ







On 29 Sep 2012, at 17:52, David T wrote:

> Dear all,
> I am not really expert in compiling so I apologise in advanced if my problem is trivial (siily).
> I am trying to compile a openMP version using gfortran. Unfortunately I have some issue that I can't fix by my own.
> This is my arch file:
> 
> # tested with gcc 4.4.0
> CC       = cc
> CPP      =
> FC       = mpif90 -openmp
> LD       = mpif90 -openmp
> AR       = ar -r
> CPPFLAGS =
> DFLAGS   =  -D__GFORTRAN -D__FFTSG -D__LIBINT -D__parallel -D__SCALAPACK -D__BLACS -D__FFTW3 
> FCFLAGS  = -g -O2 -ffast-math -funroll-loops -ftree-vectorize -march=native -ffree-form $(DFLAGS)
> LDFLAGS  = $(FCFLAGS)
> LIBS     =  -llapack -lblas -lfftw3
> OBJECTS_ARCHITECTURE = machine_gfortran.o
> 
> 
> And this is the error I had during the compilation:
> 
> ar: creating /home/dt378/cp2k/trunk/cp2k/makefiles/../lib/Linux-x86-64-gfortran/psmp/libcp2k_fft_lib.a
> ar: ctrig.o: No such file or directory
> make[2]: *** [/home/dt378/cp2k/trunk/cp2k/makefiles/../lib/Linux-x86-64-gfortran/psmp/libcp2k_fft_lib.a] Error 1
> make[2]: *** Waiting for unfinished jobs....
> make[2]: Leaving directory `/home/dt378/cp2k/trunk/cp2k/obj/Linux-x86-64-gfortran/psmp'
> make[1]: *** [build] Error 2
> make[1]: Leaving directory `/home/dt378/cp2k/trunk/cp2k/makefiles'
> make: *** [psmp] Error 2
> 
> I tried to figure out what is ctrig without succes and I am actually stuck.
> Any help?
> 
> Thanks a lot
> Davide
> 
> -- 
> You received this message because you are subscribed to the Google Groups "cp2k" group.
> To view this discussion on the web visit https://groups.google.com/d/msg/cp2k/-/dXMMVlT8dgYJ.
> To post to this group, send email to cp... at googlegroups.com.
> To unsubscribe from this group, send email to cp2k+uns... at googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/cp2k?hl=en.


-- 
The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.




More information about the CP2K-user mailing list