[CP2K:3830] OpenMP + MPI Functionality

Urban Borštnik urban.b... at gmail.com
Mon May 21 09:32:33 CEST 2012


Hi,

Have you tried the development branch?  I would also suggest a newer
version gfortran.

Cheers,
Urban.

On Fri, 2012-05-18 at 11:19 -0700, dws70 wrote:
> I've been trying to install the psmp (OpenMP + MPI) variant of CP2K
> (the 2.2 version from Oct, 2011) on a Linux cluster here. I've tried
> different compilers (ifort 12.0.4.191, gfortran 4.4) and MPI libraries
> (OpenMPI 1.4.4 and 1.5.5, MPICH2 1.4.1) and while I've had no
> difficulty compiling a binary, it invariably crashes rapidly on the
> H2O-32.inp test with MPI errors or NaN energy values. The sopt and
> popt versions of CP2K run fine on this machine but I have a user who
> wants to exploit CP2K's hybrid parallelism so I'm wondering if someone
> who has a working install of the psmp version of CP2K could give me
> some details about the configuration (compilers, libraries,
> compilation options etc.) that permitted this so I can try to
> duplicate it locally.
> 
> Thanks,
>   Daniel
> 





More information about the CP2K-user mailing list