[CP2K:3943] QM/MM grid generation error

hut... at pci.uzh.ch hut... at pci.uzh.ch
Tue Jul 31 13:31:29 CEST 2012


Hi

I don't know all the details of the code in this part.
But it looks to me that you need commensurate grids (?)
and the multi-grid code is not FFT length aware.

Some possible solutions (I'm guessing here)

1) reduce the number of grids
    CP2K_INPUT / FORCE_EVAL / DFT / MGRID / NGRIDS {1,2,3}

2) allow for more flexible FFT lengths (Should work with FFTW3)
    CP2K_INPUT / GLOBAL / EXTENDED_FFT_LENGTHS
   if this is not good enough, change the restrictions in
   cp2k/src/fft_lib/fftw3_lib.F
   to allow for more 3/5/7/etc roots

regards

Juerg


--------------------------------------------------------------
Juerg Hutter                         Phone : ++41 44 635 4491
Physical Chemistry Institute   FAX   : ++41 44 635 6838
University of Zurich               E-mail:  hut... at pci.uzh.ch
Winterthurerstrasse 190
CH-8057 Zurich, Switzerland
---------------------------------------------------------------

-----cp... at googlegroups.com wrote: -----
To: cp2k <cp... at googlegroups.com>
From: Noam Bernstein 
Sent by: cp... at googlegroups.com
Date: 07/30/2012 05:07PM
Subject: [CP2K:3943] QM/MM grid generation error

Hi - I'm trying to run various sized QM/MM regions (and corresponding
different QM cells), and for some I get the following error:


 ************************************************************************
 *** 10:20:17 ERRORL2 in pw_grid_info:pw_grid_init_setup processor 0  ***
 *** err=-300 condition FAILED at line 63                             ***
 ************************************************************************


 ===== Routine Calling Stack =====

            9 pw_grid_setup
            8 pw_env_rebuild
            7 pw_env_create
            6 qs_env_rebuild_pw_env
            5 qs_env_setup
            4 qs_init_subsys
            3 quickstep_create_force_env
            2 qmmm_create_force_env_low
            1 CP2K
 CP2K| condition FAILED at line 63
 CP2K| Abnormal program termination, stopped by process number 0

I've attached the input files - they're moderately big systems, but
don't take long
to fail.  Does anyone have any suggestions about what in the grid generation is
failing, and whether there's a systematic way to fix it (as opposed to
just tweaking
the QM cell by hand)?

          thanks,
          Noam

-- 
You received this message because you are subscribed to the Google Groups "cp2k" group.
To post to this group, send email to cp... at googlegroups.com.
To unsubscribe from this group, send email to cp2k+uns... at googlegroups.com.
For more options, visit this group at http://groups.google.com/group/cp2k?hl=en.



[attachment "0.000_GLH_conv_r_buffer_3.5_01.inp" removed by Jürg Hutter/at/UZH]
[attachment "lysozyme_GLH35_h2o_box_10.top.bz2" removed by Jürg Hutter/at/UZH]
[attachment "01.rst.bz2" removed by Jürg Hutter/at/UZH]
[attachment "BASIS_SET.bz2" removed by Jürg Hutter/at/UZH]
[attachment "POTENTIAL.bz2" removed by Jürg Hutter/at/UZH]


More information about the CP2K-user mailing list