[CP2K:3319] Compilation error with openmp

Iain Bethune ibet... at epcc.ed.ac.uk
Wed Jun 22 14:08:48 CEST 2011


You should add -D__HAS_NO_OMP_3 to your arch file to work around this.  CP2K assumes OpenMP 3 compliance.  See the 'INSTALL' file section 3.c. for details.

Cheers

- Iain

--

Iain Bethune
Applications Consultant, EPCC

Email: ibet... at epcc.ed.ac.uk
Tel/Fax: +44 (0)131 650 5201/6555
Mob: +44 (0)7598317015
Addr: 2404 JCMB, The King's Buildings, Mayfield Road, Edinburgh, EH9 3JZ





On 22 Jun 2011, at 12:18, Alin Marin Elena wrote:

> On Wed 22 Jun 2011 16:37:30 Sandeep Kumar Reddy wrote:
>> Dear all,
>>              I try to compile cp2k with openmp with intel compilers. But it
>> is terminated with following error.
>> 
>> 
>> fortcom: Error:
>> /home/sandeep/software/cp2k-openmp/cp2k/makefiles/../src/fft_tools.F, line
>> 1572: Syntax error, found IDENTIFIER 'COLLAPSE' when expecting one of:
>> PRIVATE FIRSTPRIVATE REDUCTION SHARED IF DEFAULT COPYIN NUM_THREADS
>> LASTPRIVATE ...
>> !$omp parallel do default(none) collapse(2) &
>> --------------------------------^
> 
> loop collapse is an openmp 3.0 feature 
> http://wikis.sun.com/display/openmp/Loop+Collapse
> 
> your compiler does not support it... 
> 
> regards,
> Alin
> 
> -- 
> Without Questions there are no Answers!
> _____________________________________________________________________
>  Alin Marin ELENA
>  Advanced Molecular Simulation Research Laboratory
>  School of Physics, University College Dublin
>  ----
>  Ardionsamblú Móilíneach Saotharlann Taighde
>  Scoil na Fisice, An Coláiste Ollscoile, Baile Átha Cliath
> 
>  -----------------------------------------------------------------------------------
>  http://alin.elenaworld.net
>  ______________________________________________________________________


-- 
The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.




More information about the CP2K-user mailing list