[CP2K:2771] Re: MPI2 problem on IBM Power PC

Pietro Vidossich vi... at klingon.uab.es
Tue Jun 22 10:52:33 CEST 2010


hi! we cannot run the current code, even for small systems after some steps it
crashes. we do run with an older version which uses MPI1, but now need to use
the latest code because of some bugfix. I compiled as pure MPI with the
settings below (xlf90 compiler). given the error in an MPI2 call, the admins
thought the problem was in MPI2 and tried to revise their MPI2, apparently
with no success.

PERL     = perl
CC       = mpicc
CPP      = cpp
FC       = mpif90  -qsuffix=f=F
LD       = mpif90
AR       = ar -r
DFLAGS   = -D__AIX -D__ESSL -D__FFTSG \
           -D__parallel -D__BLACS -D__SCALAPACK
CPPFLAGS = -C $(DFLAGS) -P -traditional -I
FCFLAGS  = -O3 -qstrict -q64 -qarch=ppc970 -qcache=auto -qmaxmem=-1 -qtune=ppc970
FCFLAGS2 = -O0 -qstrict -q64 -qarch=ppc970 -qcache=auto -qmaxmem=-1 -qtune=ppc970
LDFLAGS  = $(FCFLAGS)  -L/gpfs/apps/LAPACK/lib64/ 
-L/gpfs/apps/SCALAPACK/1.8/mpich2/64/

LIBS     =  -llapack -lscalapack
/gpfs/apps/SCALAPACK/1.8/mpich2/64/blacsF77init_MPI-LINUX-0.a
/gpfs/apps/SCALAPACK/1.8/mpich2/64/blacs_MPI-LINUX-0.a  \
            -lessl /opt/ibmcmp/xlmass/5.0/lib64/libmass_64.a

where mpif90 is a script with the following settings:

#!/bin/sh
#
# This script to unify the (many) possible combinations
# for the rsh command used, the object mode and the communication protocol
#
# This script will react to the following env variables :
#
# MP_IMPL=anl|lam       : Argonne (MPICH) or LAM, defaults to anl
# MP_F90=xlf90|gfortran      : defaults to xlf90
# MP_EUILIB=ip|gm|mx|shmem : defaults to gm, gm will select MPICH-GM
# OBJECT_MODE=32|64     : defaults to 64, to select the object mode,
#                         valid for mpicc/mpirun/mpirun.ch_gm)
# MP_RSH=rsh|ssh|mpd        : defaults to ssh
# MP_SHLIB=yes|no       : use shared libraries or not, defaults to yes
#
# mpicc        : honors MP_EUILIB/OBJECT_MODE/MP_CC
# mpiCC        : honors MP_EUILIB/OBJECT_MODE/MP_CXX
# mpif77       : honors MP_EUILIB/OBJECT_MODE/MP_FC
# mpif90       : honors MP_EUILIB/OBJECT_MODE/MP_F90
# mpirun       : honors OBJECT_MODE/MP_RSH (MP_EUILIB is implicit)
# mpirun.ch_gm : honors OBJECT_MODE/MP_RSH (MP_EUILIB is implicit)
#


regards, pietro
  





On Tue, 22 Jun 2010 00:50:20 -0700 (PDT), Urban wrote
> Hello,
> 
> is this a pure MPI run or is the code compiled for hybrid OpenMP/MPI?
> It is also not clear whether a different compiler has been tried or
> just different MPI implementations. Does the code work on Marenostrum
> for any other simulated system, even a simple one?
> 
> Urban
> 
> -- 
> You received this message because you are subscribed to the Google 
> Groups "cp2k" group. To post to this group, send email to cp... at googlegroups.com.
> To unsubscribe from this group, send email to cp2k+uns... at googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/cp2k?hl=en.




More information about the CP2K-user mailing list