[CP2K:2670] compile the latest version of cp2k with g95

zh vale... at gmail.com
Wed Apr 21 12:43:38 UTC 2010

Dear all,

I tried to compile the latest version (e.g. 2.1.223) of cp2k with g95,
scalapck (0.96), openmpi-1.4.1. The g95 installed on my computer
cluster is the 0.92 version built on Linux x86_64/EMT64 (32 bit
D.I.).  The fftw3, openmpi, and scalapack are compiled with this
version of g95 and installed on my machines.The following arch file
was used for compiling cp2k:
CC       = cc
CPP      = /usr/bin/cpp
FC       = /work/z-hou/soft/openmpi-g95/bin/mpif90
LD       = /work/z-hou/soft/openmpi-g95/bin/mpif90
AR       = ar -r
DFLAGS   = -D__G95 -D__FFTSG -D__parallel -D__BLACS -D__SCALAPACK -
G95_INC  = /work/z-hou/soft/fftw3-g95/include
CPPFLAGS = -C -traditional  $(DFLAGS) -I$(G95_INC)
FCFLAGS  = $(DFLAGS) -I$(G95_INC) -ffree-form -fno-underscoring  -O1 -
ffast-math -cpp -g -fbounds-check -ftrace=full   -funroll-loops
G95_LIB = /work/z-hou/scalapack_installer_0.96/lib
LIBS     = $(G95_LIB)/libscalapack.a \
           $(G95_LIB)/blacsC.a \
           $(G95_LIB)/blacsF77.a \
           $(G95_LIB)/blacs.a \
           $(G95_LIB)/libreflapack.a \
           $(G95_LIB)/librefblas.a \


The binary module of cp2k (i.e., cp2k.popt) is successfully obtained
with the above arch file. But when I run it in parallel manner, the
following errors were met:

[pcc-hs36:16109] *** Process received signal ***
[pcc-hs36:16109] Signal: Segmentation fault (11)
[pcc-hs36:16109] Signal code:  (128)
[pcc-hs36:16109] Failing at address: (nil)
[pcc-hs36:16109] [ 0] /lib64/libpthread.so.0 [0x382700e7c0]
[pcc-hs36:16109] [ 1] /work/z-hou/soft/openmpi-g95/lib/libmpi.so.0
[pcc-hs36:16109] [ 2] /work/z-hou/soft/openmpi-g95/lib/libmpi.so.
0(PMPI_Group_incl+0x172) [0x2b66ad6f87d2]
[pcc-hs36:16109] [ 3] /work/z-hou/bin/cp2k.sopt(BI_TransUserComm+0x52)
[pcc-hs36:16109] [ 4] /work/z-hou/bin/cp2k.sopt(blacs_gridmap+0x10d)
[pcc-hs36:16109] [ 5] /work/z-hou/bin/cp2k.sopt(blacs_gridinit+0xbb)
[pcc-hs36:16109] [ 6] /work/z-hou/bin/
cp2k.sopt(cp_blacs_calls_MP_cp_blacs_gridinit+0x4c) [0x2cc830c]
[pcc-hs36:16109] [ 7] /work/z-hou/bin/
cp2k.sopt(cp_blacs_env_MP_cp_blacs_env_create+0x542) [0x1b1984a]
[pcc-hs36:16109] [ 8] /work/z-hou/bin/
cp2k.sopt(qs_environment_types_MP_init_qs_env+0x1098) [0xb1ef24]
[pcc-hs36:16109] [ 9] /work/z-hou/bin/
cp2k.sopt(qs_environment_types_MP_qs_env_create+0x122) [0xb21b4d]
[pcc-hs36:16109] [10] /work/z-hou/bin/
cp2k.sopt(qs_main_MP_quickstep_create_force_env+0x12b) [0xcff143]
[pcc-hs36:16109] [11] /work/z-hou/bin/
cp2k.sopt(f77_interface_MP_create_force_env+0x1c15) [0x4f515b]
[pcc-hs36:16109] [12] /work/z-hou/bin/cp2k.sopt(cp2k_runs_MP_cp2k_run
+0x1b83) [0x4afc53]
[pcc-hs36:16109] [13] /work/z-hou/bin/cp2k.sopt(cp2k_runs_MP_run_input
+0x24d) [0x4bab8b]
[pcc-hs36:16109] [14] /work/z-hou/bin/cp2k.sopt(MAIN_+0x154b)
[pcc-hs36:16109] [15] /work/z-hou/bin/cp2k.sopt(main+0xe) [0x366f97e]
[pcc-hs36:16109] [16] /lib64/libc.so.6(__libc_start_main+0xf4)
[pcc-hs36:16109] [17] /work/z-hou/bin/cp2k.sopt [0x4abbe9]
[pcc-hs36:16109] *** End of error message ***
mpirun noticed that process rank 0 with PID 16109 on node pcc-hs36
exited on signal 11 (Segmentation fault).

>From searching the solution of the similar problem on internet, it
seems to be related to how fortran compiler handles the 32 bit and 64
bit in mpi. But I did not find out the exact solution.

I also tried the 0.92 version of g95 built on Linux x86_64/EMT64 (64
bit D.I.). The same errors were met.  I also suffered this terrible
problem when I used the intel fortran compiler on a same machine and
the pgi fortran compiler on a CARY-XT5 machine to compile the latest
version of cp2k. If anyone can give me some helps or hints to fix this
problem, I will greatly appreciate him.

You received this message because you are subscribed to the Google Groups "cp2k" group.
To post to this group, send email to cp... at googlegroups.com.
To unsubscribe from this group, send email to cp2k+uns... at googlegroups.com.
For more options, visit this group at http://groups.google.com/group/cp2k?hl=en.

More information about the CP2K-user mailing list