CP2K build with Intel Compiler and MKL

Matthias matthia... at psi.ch
Fri Sep 25 17:21:09 CEST 2009


Hi Ondrej,

I have just experienced the same behavior using the Intel compiler on
a ia64 system (Altix 4700, Itanium2). I tried several ifort compiler
releases, but none worked properly for all tests (many NaN, seg.
faults etc.). Finally, I gave up with the Intel compiler, even if it
would be obviously the first-choice compiler especially for an Itanium
system and switched to gfortran 4.4.1 which works even fine with the
pre-installed MKL. Thus the performance degradation is not that
serious, but still the price to pay for working CP2K executable.
However, if somebody knows about a working release/flag combination
for the Intel compiler, I would also appreciate this information.

Matthias

On Sep 25, 3:38 pm, Ondrej Marsalek <ondrej.... at gmail.com> wrote:
> And for added fun, even with almost the simple arch file that I can think of:
>
> http://paste.pocoo.org/show/141444/
>
> I get a failure on the same test. It looks a little bit different, but
> still has NaNs for densities. If there is anyone out there who uses
> this Intel compiler and MKL and his build can pass all the tests, I
> would really like to head from you.
>
> I don't think this is relevant, but to provide some extra information,
> just in case. This is on Ubuntu 9.04 and a Core2 E8400 CPU.
>
> Ondrej
>
> On Fri, Sep 25, 2009 at 15:24, Ondrej Marsalek
>
> <ondrej.... at gmail.com> wrote:
> > I have installed the Intel compiler version 11.0.083 (and the included
> > MKL), which is supposed to work based on what Axel said here on the
> > list as well as this page:
>
> >http://software.intel.com/en-us/articles/build-cp2k-using-intel-fortr...
>
> > However, with the arch file pasted here (optimization switched off
> > intentionally):
>
> >http://paste.pocoo.org/show/141441/
>
> > I still get a wrong build, that, for example, produces this output on
> > the test si8_pmix_otdiag.inp:
>
> >http://paste.pocoo.org/show/141440/
>
> > I would appreciate any suggestions on how to make this work. Regards,
> > Ondrej
>
> > On Wed, Sep 23, 2009 at 19:23, Ondrej Marsalek
> > <ondrej.... at gmail.com> wrote:
> >> Dear all,
>
> >> I have found that my build of CP2K with the Intel Fortran Compiler
> >> 10.1.018 and MKL 10.0.4.023 has trouble passing the tests (NaNs appear
> >> and so on). Apparently, it is miscompiled. The same setup has worked
> >> (passed all the tests) about a year. I have only updated CP2K from CVS
> >> and used a recent OpenMPI (1.3.3). I have intentionally kept the
> >> versions the same as before, to have something that is known to work.
> >> I have two questions related to that.
>
> >> Has anyone else experienced a similar problem?
>
> >> Does anyone have a tested combination of recent Intel compiler and MKL
> >> versions, perhaps together with an arch file that I could use as
> >> inspiration?
>
> >> Thanks for any replies,
> >> Ondrej
>
>


More information about the CP2K-user mailing list