problem generating basis set

Jörg Saßmannshausen jorg.sassm... at
Fri Mar 20 23:59:12 UTC 2009

Dear all,

I have a problem generating the basis set for F and the PBE functional.
Following Matthias' talk at the Tutorial, I did (in the cp2k directory):

- cvs co basis_sets
- cd basis_sets/source

I then had a look at the Makefile, change the path to blas etc. I was using 
the g95-32 compiler to compile optbas. The compilation worked without any 

I then was looking in the inpout folder for a suitable script for F and I 
found the basis-F-q7-g4 one.
Just to make sure I am not messing up things, I copied basis-F-q7-g4 and 
optbas in a different folder. Trying to follow the tutorial, I did

./optbas basis-F-q7-g4

which basically stopped here:

reading input file...

end of story, nothing happend. So I decided to try the Intel Fortran Compiler, 
recompiled, and now I get:

 reading input file...
forrtl: Illegal seek
forrtl: severe (20): REWIND error, unit 5, file /dev/pts/2
Image              PC                Routine            Line        Source
optbas             000000000057B832  Unknown               Unknown  Unknown
optbas             000000000057A7C4  Unknown               Unknown  Unknown
optbas             000000000052F6BA  Unknown               Unknown  Unknown
optbas             00000000004FC743  Unknown               Unknown  Unknown
optbas             00000000004FC030  Unknown               Unknown  Unknown
optbas             000000000050FE96  Unknown               Unknown  Unknown
optbas             000000000041667D  Unknown               Unknown  Unknown
optbas             0000000000427B9B  Unknown               Unknown  Unknown
optbas             000000000040D2FC  Unknown               Unknown  Unknown
optbas             00000000004062A2  Unknown               Unknown  Unknown          00002ADF44335154  Unknown               Unknown  Unknown
optbas             00000000004061E9  Unknown               Unknown  Unknown

Changing the optimisation level from -O3 to -O2 did not help. The compiler 
version is 10.1 20081024, the same compiler which successfully builds cp2k.

Ok, and this is where I am stuck. Is there a human input error or is there 
some other problem. I tried google, but other than Matthias' talk did not 
produced something usefull. 

Could somebody just give me a quick help and point me in the right direction?

Many thanks.

All the best from Glasgow


Jörg Saßmannshausen
Research Fellow
University of Strathclyde
Department of Pure and Applied Chemistry
295 Cathedral St.
G1 1XL

email: jorg.sassm... at

Please avoid sending me Word or PowerPoint attachments.

More information about the CP2K-user mailing list