[CP2K:1612] DFTB Zn

Juerg Hutter hut... at pci.uzh.ch
Fri Dec 5 16:25:37 UTC 2008

Hi Ben

the problem is that the parser converts the name of the
atom to uppercase (Zn -> ZN).

OK Teo beat me to this. Thanks.

However, the input worked if you include the coordinates
in the input file.
I also guess that this is the real change you did that caused
the error, not the update of the code.

You guys are much too fast. Already an aswer to the answer...


Juerg Hutter                   Phone : ++41 44 635 4491
Physical Chemistry Institute   FAX   : ++41 44 635 6838
University of Zurich           E-mail: hut... at pci.uzh.ch
Winterthurerstrasse 190
CH-8057 Zurich, Switzerland

On Fri, 5 Dec 2008, Ben Levine wrote:

> Hi Guys,
> I recently updated and recompiled my copy of CP2K, and I found a
> difficulty I previously didn't have.  I've been running some SCC DFTB
> jobs using the parameters I took from the "tests" subdirectory.  Since
> my recent update my jobs all fail with the messages:
> ERROR3 in qs_dftb_parameters:qs_dftb_param_init processor
> condition FAILED at line 198
> I dug around in the code a little and found that this is caused
> because in one place the element Zinc is stored as "Zn" and in another
> it is stored as "ZN", and these don't match up.  I tried to change the
> name in my xyz input file, but this didn't change the problem.  I'll
> upload a sample job which reproduces this problem in the following
> files:
> Zn6b.inp
> Zn6b.xyz
> Thanks for your help!
> Ben
> >

More information about the CP2K-user mailing list